Announcement

Collapse
No announcement yet.

Static mesh not updating material

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Static mesh not updating material

    I've created a copy of the "grass clump" mesh that comes with the foliage demo. I simply want my copy to use a custom material that matches the simpler visual style I aiming for. I created this material, but when I apply it to the mesh I see no change. I apply it to both LOD's and see no change. The name of the material has been changed, but nothing else. Then if I close the window and double-click on the mesh again, it declares that it's material is the original one it was given by Epic.

    I also tried this with another grass mesh that I stole from UT3 (Yes I know I can't use it in anything I sell) and it is doing the same thing.
    Why can't I change the default material? I can do this with meshes I imported new, but not this copied mesh.

    #2
    Not sure why this is happening, could I suggest just making your own mesh? Grass planes are pretty easy and would be alot less of a headache to make.

    Comment


      #3
      Just using what already comes with the UDK is even easier.
      Or at least it should be. I don't know why this isn't working...

      Comment


        #4
        Why not just use the original mesh and override the material(s) under Rendering>Materials in the properties of the StaticMeshActors in the map?

        Comment


          #5
          Originally posted by ffejnosliw View Post
          Why not just use the original mesh and override the material(s) under Rendering>Materials in the properties of the StaticMeshActors in the map?
          Because I am using this in Foliage, and I cannot find any option to change the material being used for meshes in Foliage.

          Comment

          Working...
          X