Announcement

Collapse
No announcement yet.

normal mapping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    normal mapping

    stupid question. When I import a normal map into udk I'm getting the following message "The texture you are importing is not a power of two. Non power of two textures are never streamed and have no mipmaps. proceed?" So what am I doing wrong. And how do I correct this?

    #2
    It's simply the dimensions of your texture in pixles that are wrong. So change them to something like 512x512 or 1024x1024 and it should work well. To avoid any conflicts you might want to just make the normal map the same resolution as the diffuse map for now.

    Comment


      #3
      ok got that figured out now thx. now I am gettin lighting issue? man this udk is a little bit harder then it looks. any advice

      Comment


        #4
        Textures should be in the power of two, meaning: 1x1, 2x2, 4x4.... 128x128, 256x256, 512x512, 1024x1024, 2048x2048, 4096x4096

        UDN says: "Unreal Engine 3 supports texture resolutions from 1x1 to 4096x4096. Current DirectX video adapters and game consoles support various texture resolutions from 1x1 to 2048x2048 and up to 8192x8192. The highest texture resolution supported by a specific hardware device varies by manufacturer and model. The amount of available texture memory pool also varies by the hardware. There are a number of features and settings in Unreal Engine 3 for managing the texture resolutions that are rendered for various areas such as world geometry or the user interface. "

        For more on textures: http://udn.epicgames.com/Three/Textu...dSettings.html

        --- EDIT ----

        What is the lighting issue? Can you explain what is going on, with more detail? Or, include a screenshot.

        Comment


          #5
          static mesh has invalid map cordinate index. lmao. I'm having fun tryin to figure this thing out.

          Comment


            #6
            Open up the browser, double-click the static mesh(s) that are getting the error and change the 'light map coordinate index' to "0".

            Comment

            Working...
            X