Announcement

Collapse
No announcement yet.

Materials getting some weird "rainbow" effect...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I was having this issue too.. I had to play about with the lightmaps to fix it!

    Hope that helps.

    Leave a comment:


  • replied
    if you use vertex lightmaps (if you don't have 2nd uv layout for lightmaps) things look nice on pc untill you use "mobile preview" option then you get weird rainbows
    btw on actual device /iphone4/ there was no rainbow effect but there was no baked lightmaps/shadows either

    also if you have weird normals on your mesh you might get some lighting artifacts when building lightmaps

    Leave a comment:


  • replied
    Posting an image of of the problem would be alot of help!

    Sounds like a lighting issue to me, are there overlapping UVs in your lightmap UV coordinates?

    Leave a comment:


  • started a topic Materials getting some weird "rainbow" effect...

    Materials getting some weird "rainbow" effect...

    Hey there!


    I'm in a small group trying to do a simple game that will run on the Ipad2. Everything has been working good until early today
    when all of the sudden the materials on our meshes keep getting some strange rainbow effect on them? When ever the effect
    dissapears all our models turn black instead. Until today we didnt have any problems with this.

    Let me also tell you that when this happened I didnt have alot on the screen. 4-5 custom made meshes with their material on
    and a simple square brush as a floor.

    The lightsource I was using was a dominant directional lightsource (also whenever the meshes went black, moving the light turned them on again until the light was rebuilt).

    Has anyone else had any problems with this and maybe found why it's like this?
    If so I would love to hear the solution.

    //Havock
Working...
X