No announcement yet.

Combined textures gets artifacts but only inside UDK

  • Filter
  • Time
  • Show
Clear All
new posts

    Combined textures gets artifacts but only inside UDK

    I have a combined texture that is composed of 4 different heightmaps - each of them located on it's own channel (RGB and A).
    Now inside the material editor when I use only one of these channels as a texture sample, I get tiny artifacts. The artifacts seem to appear because UDK collects color information from a different channel.
    The thing is that it's not my source file that's causing the problem. My 32-bit TGA is flawless. I did double check this in Photoshop by opening the TGA, and looking at each color channel to see if I could spot these artifacts - but they are not there.

    I made the composed texture like this in Photoshop:

    Diffuse set/group
    ---Red set/group (blend mode: screen)
    ------Layer filled with color 255,0,0 (blend mode: multiply)
    ------Layer with my greyscale heightmap
    ---Green set/group (blend mode: screen)
    ------Layer filled with color 0,255,0 (blend mode: multiply)
    ------Layer with my greyscale heightmap
    ---Blue set/group (blend mode: screen)
    ------Layer filled with color 0,0,255 (blend mode: multiply)
    ------Layer with my greyscale heightmap

    The result is a composite texture that looks like **** if you view it with all channels active - but with only one channel active at a time you see a perfect heightmap.
    So who is UDK giving me artifacts despite the fact that it's nothing wrong with the source. - source file in case you are interested

    Are these 'artifacts' those little black squares? If so, I've been getting those as well

    And another thing, what happens if you put the heightmaps directly in the channels in Photoshop?


      Yes tiny black squares (or dark grey).
      Afaik you cannot past anything into a channel (other than the alpha) in photoshop. You can stripe a layer/image of it's color information though by painting the channels black when you have a layer selected though.


        Well, I know I can in Photoshop =/

        In the bit where you have your layers, it should also say 'Channels' on a tab, if you click that, you can edit any of the channels in any way you like, albeit monochrome

        As per the real problem, not sure what's causing it, but I've seen it happen a lot in the latest build. This afternoon I was testing it out a bit, to see if I can pinpoint the problem, but UDK seems to have issues with multiple textures, as in, multiplying them, lerping them, etc.

        I don't recall seeing it as often before as I have recently..

        What's your video hardware?
        I have two HD6950's, maybe it's an AMD issue? ( I had a GTX570 before the release of August UDK )


          I don't have the channels hidden behind my layer window: I've moved it elsewhere because I use it so frequently. Didn't know you could paste directly into a RGB channel though - last time I tried it it didn't work. But now I found out that it's very important that the copied area is monochrome or it's not possible to paste it.

          I have one old nVidia GeForce 7800GTX card. I doubt hardware is the issue though - it's UDK.


            You managed to make it work?
            I donwloaded your TGA image and imported it into UDK. While importing the image you can chose diferent "Compression Settings".

            The default compression setting, will make the texture looks like it:

            I tried all the other compression settings, the one that looked better was TC_SimpleLightmapModification, it will make your image looks like it:

            I don't think you will be able to get any better results using that aproach.


              Great, I'll try that. Thanks a bunch.