No announcement yet.

Noobs trying to work with UDK

  • Filter
  • Time
  • Show
Clear All
new posts

    Noobs trying to work with UDK


    Me and my friends are working on a game. We tried many things to import our files, to edit some things, and many other questions. asking everything on this forum requires us to wait everytime we want to know something. I wondered if some of you know a site where we can find clear information and tutorials about how to work with UDK.

    kind regards.

    this should help


      The 3D Buzz Video Tutorials are an excellent place to start, especially the User Interface and Simple Level videos.

      They were released almost two years ago for the first releases of the UDK, but they are still as relevant as ever.


        ... google is always your friend.




            Hello can anyone help please
            I am using udk 3and latest update and someone has made me level I have the udk file and the upk file. If I open the udk file on its own there is no textures so I open the upk file in the external folder then reload the udk map then it works but when I press play it says

            This map is using externally referenced packages which won’t be found in game and reference will be broken. Perform a map check for more details.

            I do this and loads of errors pop up which I don’t understand but also when I try to rebuild lighting as asked it says cannot connect to swarm.

            As you can tell im a complete noob and probably have the answer staring m in the face but iv looked over youtube and read lots of info from the udk website but nothing answers really what im asking so can anyone help please


              1. These are both just warnings, the first (externally referenced packages), will cause you pain down the road so its a good idea to address it now. First figure out where you installed UDK. What's the file path? When you know that then copy the UDK file and all UPK's inside that UDK file folder, otherwise UDK can't find the resources (it doesn't know to search your whole hard drive looking for them).... So try putting all the files into the .\..\UDKGame\Content sub-folder allowing for whatever top-level folder you used to install UDK i.e. maybe you used C:\UDK or maybe you used C:\Program Files\UDK\ etc... Afterwards if you're still encountering problems start UDK and right click on each of the packages and choose 'fully load' to ensure UDK compiles the shaders...

              2. Swarm is optional, its a distributed light-building system. But this process can all be done on a single local machine, it may just take longer... So you can ignore the warning / error. Instead shutdown the Swam app in the taskbar to ensure UDK manages the light building locally... See these links for more info...

              3. This thread is from 2011. Try not to resurrect zombie threads, instead post new ones. But only after you've tried to use the Advanced Search to get answers first i.e. researching Swarm etc...