Announcement

Collapse
No announcement yet.

Trouble setting the default game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble setting the default game

    I've gone through several tutorials to setup a basic project, yet everytime I run UDK it still loads the Deathmatch game. If I go through the editor, it uses the proper game mode by default, and it uses the correct map. I am using the 2011-07 release.

    My DefaultGame.ini
    Code:
    [Engine.GameInfo]
    ;DefaultGame=UDKBase.SimpleGame
    ;DefaultServerGame=UDKBase.SimpleGame
    DefaultGame=BSGame.BSGame
    DefaultServerGame=BSGame.BSGame
    ;PlayerControllerClassName=UDKBase.SimplePC
    PlayerControllerClassName=BSGame.BSPlayerController
    GameDifficulty=+1.0
    MaxPlayers=32
    ;DefaultGameType="UTGame.UTDeathmatch";
    DefaultGameType="BSGame.BSGame";
    My DefaultEngine.ini
    Code:
    [URL]
    MapExt=udk
    ; Any additional map extension to support for map loading.  
    ; Maps without an extension always saved with the above MapExt
    ;AdditionalMapExt=mobile
    ;Map=UDKFrontEndMap.udk
    Map=ExampleMap.udk
    ;LocalMap=UDKFrontEndMap.udk
    LocalMap=ExampleMap.udk
    ;TransitionMap=EnvyEntry.udk
    Code:
    [UnrealEd.EditorEngine]
    +EditPackages=UTGame
    +EditPackages=UTGameContent
    +EditPackages=BSGame

    My Launch.log
    Code:
    [0004.92] Log: Steamworks is unavailable
    [0005.08] Log: LoadMap: ExampleMap?Name=Gabriel?Team=255
    [0005.11] Log: 
    [0005.11] DevMemory: Memory allocations reported by the OS: 246.88 MB (with 0.00 MB waste)
    [0005.11] DevMemory: Virtual memory tracked in the allocators: 112.82 MB (with 102.60 MB used, 2.86 MB slack and 7.35 MB waste)
    [0005.70] Log: Game class is 'UTGame'
    What am I missing? I'm sure the answer is pretty obvious but any help would be appreciated.

    #2
    have you also set you gametype to use your map as the default map

    Code:
    [UT40kTeamGame UTUIDataProvider_GameModeInfo]
    GameMode=UT40k.UT40kTeamGame
    GameSettingsClass=UTGameSettingsTDM
    GameSearchClass=UTGameSearchTDM
    PreviewImageMarkup=UT40k_UI_Materials.GameTypes.UT40k_GametypePic_Default
    DefaultMap=UT40kTDM-TeamGame
    Prefixes=UT40kTDM
    OptionSet=UT40kTDM
    IconImage=UI_HUD.HUD.UI_HUD_BaseD
    IconU=571
    IconV=76
    IconUL=149
    IconVL=105
    FriendlyName=UT40k_TeamMatch
    Description=UT40k Team Match
    EndOfMatchRulesTemplateStr_Scoring=First to make `g frags wins
    EndOfMatchRulesTemplateStr_Time=most frags in `t mins. wins

    Comment


      #3
      No I haven't set up a GameModeInfo section. I didn't see a tutorial on that, what does this accomplish?

      Also, the correct map is already loading so I'm not sure this will solve anything, but I'm willing to give it a try.

      Comment


        #4
        1) Have you set your game type in the World Properties via the editor?

        2) Is your map prefixed with DM- ? The section under DefaultGameType will set it to Deathmatch based on the prefix...

        Comment


          #5
          The default Game Type was the problem. The ExampleMap was set to UTGame, as soon as i switched those to none it worked just fine.

          Thanks.

          Comment

          Working...
          X