Announcement

Collapse
No announcement yet.

Cell/Toon shader problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cell/Toon shader problem

    I have problem with my shader. I built my own custom Cell/Toon shader and in the viewport of the material it works just fine. But when i rebuild the scene and preview in mobile it's not working. Any ideas what Am I doing wrong ?
    Here are few screens of the shader and the problem.
    Is the problem in lightning/postprocess/world options or where ?
    Just can't get it to work for mobile. ;/

    Those are the example shaders i fallow for building my own :


    Here is the shader i've made :






    #2
    I've made another test.
    Convert the Camel to " Mover " Then when i hit the Ordinary play button. The cell shader is working !! But when i try the mobile preview Button the shader is not working.

    So i'm thinking that way -> In the DefultEngine Config file there is something turned off ?

    Ideas guys ?

    Comment


      #3
      Post process shaders are not supported on mobile so it will not work.

      Comment


        #4
        So i should only use diffuse channel, normal, spec?

        And one more question. How many lights are supported ... can't find the answer.

        Any idea of making toon/cell effect ? Except hand paint the textures

        Comment


          #5
          Originally posted by Archerx View Post
          Post process shaders are not supported on mobile so it will not work.
          How you manage to make that edge black for your game? If it's not a secret

          Comment


            #6
            You can use an old trick which is to simply make a slightly larger version of the mesh, inverse the mesh faces and use a black unlit texture.

            Comment


              #7
              Originally posted by Solid Snake View Post
              You can use an old trick which is to simply make a slightly larger version of the mesh, inverse the mesh faces and use a black unlit texture.
              10x dude for the info.

              Here is the result i've get. I'm very pleased with the first test to be honest.

              So how i've made it :
              1) Inverted faces on second mesh
              2) Separate Emissive texture
              3) Diffuse texture
              4) Simple light

              If you have any suggestions of improving that effect i would love to hear it.
              10x guys!

              And here is the cartoony look:

              Comment


                #8
                I kinda can't see the pics.

                Comment


                  #9
                  Can't see them either.

                  Comment


                    #10
                    Now they must work ?

                    Comment


                      #11
                      Originally posted by Solid Snake View Post
                      You can use an old trick which is to simply make a slightly larger version of the mesh, inverse the mesh faces and use a black unlit texture.
                      This is what I did but it doubles your poly count so consider that.

                      Comment


                        #12
                        Polygon counts rarely matter these days, and to some extent the same thing can be said on the iOS devices too. What matters more, is the number of draw calls on the device.

                        Comment


                          #13
                          thx guys for the feedback. Anyway if someone find better looking way of doing the cartoon stuffs please post it !

                          Comment

                          Working...
                          X