Announcement

Collapse
No announcement yet.

UDK Frontend - Adding a map preview to the map menu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Frontend - Adding a map preview to the map menu

    Hi,

    I've just cooked a mod i made in udk and all works fine, there is however one snag. When you select the map you want to join, there is no image of the map on the right, just a blocky icon saying "img". Obviously this is where a screenshot of the map would go, but how do you get a screenshot there? I've looked everywhere in Frontend but see no obvious answer as to where to find the image i want to use. Do you have to copy and paste the screenshot into a certain folder before cooking it?

    Thanks,

    Chris

    #2
    Chris,

    Took me awhile to find this one also. It is set in the UDKGame.ini Close to the bottom you will find an entry for each map that looks like this:

    [vCTF-Necropolis UTUIDataProvider_MapInfo]
    MapName=vCTF-NECROPOLIS
    PreviewImageMarkup=UI_FrontEnd_Art.MapPics.___Map-Pic-vCTF-Necropolis
    Description=<Strings:UTGAMEUI.CampaignBriefing.Bri efDesc38>

    You will need to create an entry for each map and also add a pic to the UI_FrontEnd_Art.MapPics or your own package.

    Hope this helps.

    Donald

    Comment


      #3
      Almost works for me

      Thanks for the info, I was looking for this for a while as well. I found the section where I needed to add the code, added it, test played it and it worked great. When I packaged the game I didn't retain that information. So "play on PC" worked great but the packaged version didn't.

      Do you have any idea why it would be doing this? Did it work in the packaged version on yours.

      Thanks,

      Mike

      Comment


        #4
        yes you have to make sure the package with your pic is cooked found in the DefaultEngine.ini

        Code:
        [Engine.PackagesToForceCookPerMap]
        .Map=UDKFrontEndMap
        .Package=UDKFrontEnd
        .Package=UI_FrontEnd_Art
        .Map=UT40kFrontEndMap
        .Package=UDKFrontEnd
        .Package=UI_FrontEnd_Art
        .Package=UT40k_UI_Materials
        ;.Package=UT40k_UI_Test
        .Map=UT40kGfxFrontEndMap
        .Package=UT40kFrontEnd
        mentioned in my video tutorials

        Comment


          #5
          Still trying to get it to work

          I thought about that but wasn't certain how to do it. So I added in the lines to force cooking the map and package but that didn't work.

          The texture is in the correct package, and it has a material and has been applied in the scene.
          The DefaultEngine.ini file has been updated and saved.
          I made certain frontend recompiled and cleaned everything before packaging, just in case.
          All the naming conventions match with no spelling errors.

          At this point I'm not certain what else to check. Could you look over the screenshot and see if anything looks wrong?
          Does the package need to be saved in a specific location?

          Mike

          www.michaelordway.com/Storage/screen.jpg

          Comment


            #6
            ok take a tip from me, put all your map pic's into a sepperate package i don't think it will work from a map package.
            the same goes for all your UI content

            ps. might also be a good idea to put all you maps/content into it's own folder set, like i show in my UDK Basics Tutorial video's

            Comment


              #7
              No luck

              So I moved the image to its own package and changed all the references to it throughout the code, no luck. I included another screenshot with all the code changes that I've made highlighted. When it plays on PC it runs fine and does what it is supposed to do the image appears and the map name and description appears correctly. When packaged it seems like it's ignoring everything that was added in the UDKgame.ini file.

              I appreciate all the help, it's very difficult finding someone who can answer more than the basics in UDK.

              Mike

              www.michaelordway.com/Storage/screen2.jpg

              Comment


                #8
                @Geodav So I took a look at your "setting up a basic game" tutorial and got the images to cook with the rest of the package. It looks like I can confirm that if the textures are in a map package they will NOT cook. Even if you move the textures to their own package after the fact it still doesn't want to cook properly. (That may have been a glitch in UDK, or myself)

                Thanks a lot it was a great help!

                There is one other thing bugging me though. I tried getting the game to recognize my custom game type as the default and I noticed the following lines in "defaultgame.ini"

                [Engine.GameInfo]
                DefaultGame=UDKBase.SimpleGame
                DefaultServerGame=UDKBase.SimpleGame
                PlayerControllerClassName=UDKBase.SimplePC
                GameDifficulty=+1.0
                MaxPlayers=32
                DefaultGameType="UTGame.UTDeathmatch";
                +DefaultMapPrefixes=(Prefix="DM",bUsesCommonPackag e=FALSE,GameType="UTGame.UTDeathmatch")
                +DefaultMapPrefixes=(Prefix="CTF",bUsesCommonPacka ge=FALSE,GameType="UTGameContent.UTCTFGame_Content ")
                +DefaultMapPrefixes=(Prefix="VCTF",bUsesCommonPack age=FALSE,GameType="UTGameContent.UTVehicleCTFGame _Content")

                I took the three lines that looked like they controlled the default gametype and changed them to my game

                [Engine.GameInfo]
                DefaultGame=folderstructuregame.newgametype
                DefaultServerGame=folderstructuregame.newgametype

                PlayerControllerClassName=UDKBase.SimplePC
                GameDifficulty=+1.0
                MaxPlayers=32
                DefaultGameType="folderstructuregame.newgametype";
                +DefaultMapPrefixes=(Prefix="DM",bUsesCommonPackag e=FALSE,GameType="UTGame.UTDeathmatch")
                +DefaultMapPrefixes=(Prefix="CTF",bUsesCommonPacka ge=FALSE,GameType="UTGameContent.UTCTFGame_Content ")
                +DefaultMapPrefixes=(Prefix="VCTF",bUsesCommonPack age=FALSE,GameType="UTGameContent.UTVehicleCTFGame _Content")


                But whatever I change it doesn't change the default loaded gametype when the game is launched.

                Does anyone have any suggestions? Is there another value that I haven't found yet.

                Mike

                Comment

                Working...
                X