Announcement

Collapse
No announcement yet.

Alternative to creating a Bump Offset?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Alternative to creating a Bump Offset?

    So I was following 3DMaxx's tutorial and I am at the one where he crates a bump offset for his material. He uses the Normal Maps Alpha channel as a height map, and it works out great. However my Normal Map doesn't have an Alpha Channel whatsoever, and the same with the actual texture. So is there another way to make a Bump Offset? Perhaps making my own Heightmap? If that would work, well what do I do?

    #2
    The reason they use the alpha channel is because they stored the height map in the alpha channel--if you imported a separate height map that would be a bunch of data you wouldn't need since a grayscale height map only needs one channel. So just create your height map and add it to your normal map as an alpha channel.

    Comment


      #3
      Originally posted by darthviper107 View Post
      The reason they use the alpha channel is because they stored the height map in the alpha channel--if you imported a separate height map that would be a bunch of data you wouldn't need since a grayscale height map only needs one channel. So just create your height map and add it to your normal map as an alpha channel.
      And how would one go about and do this? I use Photoshop CS5 Extended, and I am not that great with it :/.

      1: How do I create a height map in Photoshop CS5.

      2: How do I put the height map in the Alpha Channel of my Normal Map..

      Thanks you!

      Comment


        #4
        Usually you would use render to texture with 3ds Max to render a height map, but you can also draw it yourself

        Basically, you would draw over the image, stuff that you want to look higher you would use something closer to white (white would be the highest something would appear) and something that you want to look lower would be closer to black (black would be the lowest it would appear) so if you have something with a panel that's supposed to look like it's raised, you might make that white with the rest of it being gray, and then maybe you would make stuff like a crack black so it looks lower.

        In Photoshop, you would open your normal map, then on the right you have your layer window--in there should be a tab called Channels, and when you switch to that you would see 3 channels, Red, Green, and Blue. To add an Alpha channel, just click the button at the bottom called Create New Channel (it's the same icon as you would click to add a new Layer) and it'll add an alpha channel. You would just then paste your height map there.

        Then, save as a 32-bit .tga file and when you import it into UDK it'll have an alpha channel you can use.

        Comment


          #5
          Originally posted by darthviper107 View Post
          Usually you would use render to texture with 3ds Max to render a height map, but you can also draw it yourself

          Basically, you would draw over the image, stuff that you want to look higher you would use something closer to white (white would be the highest something would appear) and something that you want to look lower would be closer to black (black would be the lowest it would appear) so if you have something with a panel that's supposed to look like it's raised, you might make that white with the rest of it being gray, and then maybe you would make stuff like a crack black so it looks lower.

          In Photoshop, you would open your normal map, then on the right you have your layer window--in there should be a tab called Channels, and when you switch to that you would see 3 channels, Red, Green, and Blue. To add an Alpha channel, just click the button at the bottom called Create New Channel (it's the same icon as you would click to add a new Layer) and it'll add an alpha channel. You would just then paste your height map there.

          Then, save as a 32-bit .tga file and when you import it into UDK it'll have an alpha channel you can use.
          Thanks for your reply.

          So I made a Heightmap with 3DSMax with the following video tutorial...

          http://www.youtube.com/watch?v=V5QD6D9pYfE

          When at the end he rendered the map, I saw a "save as image" option and used that. First saved it as .tga,, than .png. You will see why later...

          Anyway so I go to the Normal Map, and make a new channel. Now I drag and place the tga, but I don't see anything. It is there, as I am able to shrink and expand the dimensions, but as far as I am concerned it is just a border encompassing nothing... It actually just makes a new LAYER....

          I tried with a PNG instead, and same results.....

          So......

          Comment


            #6
            There are 16bit and 32bit versions of both png and TGA, 16 records 3 chan (RGB) and 32bit records RGBA, the A being the alpha chan along with it. If you save a TGA which has a alpha channel in 16bit it will discard it, this is probably what you are doing.

            In photoshop, when you go to save an image as a TGA there will be a checkbox on the save dialogue that has 'alpha' lable, make sure this is checked then it will ask if you want to save 16bits/pixel or 32bits/pixel choose the latter and it will save the alpha chan.

            Comment


              #7
              Originally posted by Ghiest View Post
              There are 16bit and 32bit versions of both png and TGA, 16 records 3 chan (RGB) and 32bit records RGBA, the A being the alpha chan along with it. If you save a TGA which has a alpha channel in 16bit it will discard it, this is probably what you are doing.

              In photoshop, when you go to save an image as a TGA there will be a checkbox on the save dialogue that has 'alpha' lable, make sure this is checked then it will ask if you want to save 16bits/pixel or 32bits/pixel choose the latter and it will save the alpha chan.
              That is not what I am having problems with. I am trying t o supposedly get the heightmap in the alpha channel in photoshop.....

              I have also been saving my TGA's as 32/bit the whole time so....

              Comment


                #8
                When you go to the Channels tab, add the alpha channel (which won't be visible by default after you make it) and then check the eye box beside it so you can see it, then just paste

                Comment


                  #9
                  Originally posted by darthviper107 View Post
                  When you go to the Channels tab, add the alpha channel (which won't be visible by default after you make it) and then check the eye box beside it so you can see it, then just paste
                  Ok tell me if I am doing something wrong

                  1: Open up the Normal Map (Which is a 32/bit RGBA tga file, generated in crazybump) in photoshop

                  2: Make a new Channel in the channels tab. It appears as Alpha1.

                  3: Hit the Space to the left of the channel to make the Eye Ball Appear, and the eye ball to the left of the RGB channel to make everything else disappear.

                  4: Drag and place the heightmap I generated with Crazybump (it is a lot easier for me. It says "displacement" but looks exactly like a heightmap. This is also a 32/bit RGBA .tga file) in the big black space I see.

                  After that it AUTOMATICALLY creates the new LAYER containing the heightmap, and the picture is still black until I turn on the RGB channel again. When I do, I see the displacement map in the way! I have to delete the layer to actually get my original image!

                  Comment


                    #10
                    If you're starting off with a 32-bit image, make sure it doesn't already have an alpha channel--if it's named Alpha1 rather than just Alpha that usually means it does. Otherwise, you don't have to create a new channel, you can just paste into that one.

                    If it's creating a new layer, rather than pasting into the channel, then you don't have the Alpha selected, make sure the alpha channel is selected and visible when you paste.

                    Comment


                      #11
                      Originally posted by darthviper107 View Post
                      If you're starting off with a 32-bit image, make sure it doesn't already have an alpha channel--if it's named Alpha1 rather than just Alpha that usually means it does. Otherwise, you don't have to create a new channel, you can just paste into that one.

                      If it's creating a new layer, rather than pasting into the channel, then you don't have the Alpha selected, make sure the alpha channel is selected and visible when you paste.
                      Funny thing, in the channels tab I only see RGB, Red, Green, and Blue, but when I add a new channel it still says "Alpha 1". I also decided to just start with 24/bit images, by deleting the 32 bit ones, and replacing them with 24/bit ones...

                      Ok so here is my screen. This is with the new channel made, it selected, and visible.....



                      Take note of the other tgas also. The first one is the regular diffuse, second one is the heightmap, and the last is the normal map. I opened the Normal Map.



                      WITH THE ALPHA CHANNEL STILL SELECTED, I drag and drop the Heightmap. This happens.



                      I place the image, re enable the RGB channel, and this happenes....

                      Comment


                        #12
                        Actually, I was wrong about the Alpha/Alpha 1 thing, when you create a new alpha channel it will be named Alpha 1, I couldn't check it yet so I wasn't sure


                        Don't drag and drop, copy and paste

                        Comment


                          #13
                          Originally posted by darthviper107 View Post
                          Actually, I was wrong about the Alpha/Alpha 1 thing, when you create a new alpha channel it will be named Alpha 1, I couldn't check it yet so I wasn't sure


                          Don't drag and drop, copy and paste
                          Ehh maybe that is whats wrong. You see, I make the channel, select it, copy the Displacement Map in Windows Explorer, but I can't just "paste" it. I hit Control V, nothing happens, even though I AM SURE I copied it. I have actually had this problem for a long time now, with every photoshop release ranging from CS3...

                          Comment


                            #14
                            You can't just copy a file--you have to copy an image, open the file in photoshop, use the marquee selector and select the whole area, or just press CTRL+A and then copy, and then paste.

                            I file in the Windows Explorer is a different object type. And dragging a file into a program would be for opening the file rather than copying.

                            Comment


                              #15
                              Originally posted by darthviper107 View Post
                              You can't just copy a file--you have to copy an image, open the file in photoshop, use the marquee selector and select the whole area, or just press CTRL+A and then copy, and then paste.

                              I file in the Windows Explorer is a different object type. And dragging a file into a program would be for opening the file rather than copying.
                              Ahh so far so good! I now have the Heightmap in the Alpha Channel of my Normal Map. Now let me just follow the tutorial again and I will get right back to you

                              Thank you so far! '

                              Also P.S, when saving do I select "Alpha Channels" when saving this as a .tga?

                              Comment

                              Working...
                              X