Announcement

Collapse
No announcement yet.

About the new subsurface scattering material links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    About the new subsurface scattering material links

    I saw in the material a few link options in the material editor that I never saw before (but didn't download the new UDK for several months):

    SubsurfaceInscatteringColor
    SubsurfaceAbsorptionColor
    SubsurfaceScatteringRadius

    and the property:

    Enable Subsurface Scattering

    Has anyone got it to work?

    I tried connecting textures/constants but nothing seemed to work.

    I was already thrilled with the skin shader by migusan (http://forums.epicgames.com/showthread.php?t=732232), but native support would be great too.

    #2
    It is likely that these are DX10 or 11 features, but I am not sure myself.

    Comment


      #3
      I believe there's an INI setting for subsurface scattering, and I'm also not sure if it uses DX11 or not.

      Nothing in Unreal requires DX10 to work

      Comment


        #4
        Wernt they showing subsurface scattering off aaaages back with GoW tech demos (early UE3)?

        Comment


          #5
          Thanks guys, it is indeed an ini setting (AllowSubsurfaceScattering), didn't think of that.

          Just a quick render without and with the sss:

          [shot]http://i1120.photobucket.com/albums/l482/charlo020/unreal-engine-sss-test-01.jpg[/shot]

          Comment


            #6
            Originally posted by Charles View Post
            Thanks guys, it is indeed an ini setting (AllowSubsurfaceScattering), didn't think of that.

            Just a quick render without and with the sss:
            Looks great! Can you post more info on how you did this? A screenshot of the shader perhaps?

            Comment


              #7
              Originally posted by ghostface View Post
              Looks great! Can you post more info on how you did this? A screenshot of the shader perhaps?
              its already in UDK

              http://udn.epicgames.com/Three/MaterialExamples.html

              Comment


                #8
                wow did you model that character yourself (or an artist in your team)?

                Comment


                  #9
                  Originally posted by Hboybowen View Post
                  No, that's the old Transmission 'subsurface scattering', there are new material links now.

                  Comment


                    #10
                    Originally posted by ghostface View Post
                    Looks great! Can you post more info on how you did this? A screenshot of the shader perhaps?
                    It's really easy, just connect your diffuse texture to the SubsurfaceinscatteringColor for example, and link a New Constant with value 1 to 10 to the SubsurfaceScatteringRadius. Then click the material and check the Enable Subsurface Scattering option, that's all. For more advanced scattering you would have to create additional maps for the InscatteringColor and AbsorptionColor.

                    @Baphomeh: no, this is the model from the nVidia Human Head demo. We extracted the 3D model from that installer some years ago so that we could study the subsurface scattering simulation.

                    Comment


                      #11
                      Has this option been removed from the newer releases?

                      Setting AllowSubsurfaceScattering=True on the UDK-2011-01 release gives the option to check the Enable Subsurface Scattering tickbox and get the new SSS functions working on the material.

                      Setting AllowSubsurfaceScattering=True on the UDK-2011-02 release doesn't give the same option so hooking up nodes to the new subsurface scattering inputs doesn't show any changes to the material.

                      Is there something else I need to change in the UDK-2011-02 release to get the new SSS to work the same way they did in the UDK-2011-01 release?

                      Comment


                        #12
                        I believe these are now DirectX 11 features.

                        Comment


                          #13
                          How do I enable them in the UDK-2011-02 release then? Or do they only become enabled when using the editor with a DX11 enabled card?

                          If they are DX11 only how come they worked on my age old DX9 card only a few months ago? Im just using UDK for a custscene\ non-playable demo at the moment so framerate etc isn't an issue really if that's why they have been moved to DX11 only.

                          Comment

                          Working...
                          X