Announcement

Collapse
No announcement yet.

Reflection offset in screenspace when adding normals

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Reflection offset in screenspace when adding normals

    I'm creating a real-time reflection, and have followed some tutorials which all say this is the way to do it. I feel like I'm doing exactly as they do, but I still get a weird effect. I think the following screen shot explains it all. But here's a description: I'm adding the normals to the screen pos UVs in order to get some distortion on the reflection itself. This error occurs regardless if I'm in game or in the editor. How can I offset back this to make sure that I don't get the edge and that the reflection stays where it supposed to be, while maintaining a distortion? I think it has something to do with the normals only being positive thus moving the whole thing, but I've tried normalizing them and subtracting some of them etc... not really working.
    [SHOT]http://imgur.com/dPOxW.jpg[/SHOT]

    #2
    That's a bug that's been in the engine for a long time. I've never found any way to fix it.
    The good news is that people have also mentioned that this bug only happens in the editor. It doesn't happen in the cooked game. Not sure if that's true or not.

    Test it in the actual game instead of PIE and see if it's still there.

    Comment


      #3
      I tried what you said, and the same thing happens. I even tried to cook and create a new install for the entire game, same result.
      What's odd is that the tutorials I'm following doesn't seem to have this problem. I.e. this guy.

      Comment


        #4
        I've had that problem every time I've ever mixed normals and render textures. I just don't do that any more. I'd love to get an answer too. All I've heard in the past is that it's a known bug and that it seemed to be fixed for final games in the most recent version of UDK. I guess it's not as fixed as they thought.

        Comment

        Working...
        X