Announcement

Collapse
No announcement yet.

Strange Light Splotches

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange Light Splotches

    Hello

    Please have a look at the attached image.
    All settings are default, basic Additive Level, one omni light, and standard lightmass.

    Anyone knows what can cause these strange splotches of light on the model or textures ?

    Please help. Thank you



    Uploaded with ImageShack.us

    #2
    looks like there are multiple faces in one spot perhaps

    Comment


      #3
      Its a static mesh imported from 3dsmax.
      I checked for double faces in max and there are none. On top of that that model imported in Unreal has the exact same number of faces as in Max so the Export Import went fine.

      I am really thinking its a problem of light, to be more precise LightMass.
      But I have no proof on that.
      Neither do I know where to start in solving this issue.

      Comment


        #4
        a video would help seeing the issue more clearly i think

        Comment


          #5
          what do the uv's look like? if you convert it to a 'mover' object, does the splotches go away?

          Comment


            #6
            I've never seen lightmass have this kind of effect. It could if your uv's or normals or specularity were confused.
            I give this link to everyone who might have issues with max models in UDK because he gives a few good pointers specific to getting results in UDK:
            http://www.chrisalbeluhn.com/3D_Tutorials.html

            You may wanna browse through a few of them and see if you notice any gems of wisdom.

            Other than that, I noticed that two of the odd lit spots almost form a line halfway up the model.

            Is it possible that your normals or spec are tiling on accident? Are they a different size from the diffuse? (They can be different sizes. It just may make them tile sometimes, depending on how the material is set up.)

            Can you post a screen shot of your material setup? If it's not a Max/UDK thing, then it'll probably be a material thing.

            For reference, here are the pages on all of the lightmass tweaks:
            http://udn.epicgames.com/Three/Lightmass.html (Basic Settings)
            http://udn.epicgames.com/Three/LightmassTools.html (Debugging)
            http://udn.epicgames.com/Three/LightMapUnwrapping.html (UV setup)

            Comment


              #7
              Hi

              Here is the material setup.
              Simple master material then instances of it for each part of the building.
              The only parameter is the texture used for diffuse.
              The texture is s simple tga file output from max to test the AO pass in max and multiply the diffuse pass in Unreal.

              I'm doing this just because the UDK Ambient Occlusion is kinda poor in quality.

              Comment


                #8
                Percydaman had a good test. Try right clicking on it and changing it to a Mover object. See if it goes away. Since movers are dynamic, they don't use lightmass lightmaps.

                Your material is fine. All I can think of at this point is some UV issue.
                Read up on uv's in UDK and see if you have any compatability issues... Layered uvs, not enough spacing, etc. It's explained fairly well in the link I gave above.

                If it's not uv's, I'm out of ideas.

                You could try increasing the lightmass resolution (Also explained in the lightmass links above), but this doesn't seem like that kind of an issue.

                Comment


                  #9
                  Hmm

                  First of all. I have converted the static mesh into a mover and indeed the issue faded away. But another one came into place. Now I have some weird Yellow Light hitting the surface in some places. Dont really know why. Then again this might be the material.
                  But the problem now is that the shadows are not as accurate as before and the backside of the object receives too much light from indirect I suppose.

                  Second: here are the UVW's. UVW channel 0 is for diffuse and it is layered. 1 layer for each material, and 4 of them in total. UVW channel 1 is for lightmaps and this one is not layered.



                  Uploaded with ImageShack.us



                  Uploaded with ImageShack.us

                  Comment


                    #10
                    yes, dynamic objects don't get the same kind of lighting as static objects. Since I'm still kinda new to UDK, I'm trying to get a handle on this as well. But it was only intended as a troubleshooting step. So it looks like its something to do with lightmass. what is the quality preset your using with lightmass? how does it look with production quality if your not using it? Does the issue go away if you remove the ao texture and just use a color for the diffuse?

                    Comment


                      #11
                      Just in case you did not: have you set smoothing groups correctly?

                      Comment


                        #12
                        LightMass is set to default values. I have not made any changes there.
                        Smoothing Groops import corectly as far as I can tell. (I get same smoothing results are in 3dsmax - so I guess its all correct there.)

                        If I put a simpler texture on the diffuse channel with just a color or maybe very little variation of color in the image, the issue is still visible.

                        But in my case the issue is not visible anymore due to the texture. I know its still there just not visible.



                        Uploaded with ImageShack.us

                        Comment


                          #13
                          build lighting quality is on production not preview, right?

                          EDIT: appears someone asked earlier

                          what if you edit the model so that it's just a low poly cylinder (or make several versions, each less detailed), then check if the issue still appears

                          Comment


                            #14
                            Try playing around with the IndirectNormalInfluenceBoost setting in world/lightmass settings. Default value is 0.3 iirc, try putting it to 0 and see if the blotches go away.

                            Comment


                              #15
                              Here is a comparison of 2 quality builds: Preview and Production.

                              U see that the production build quality kinda solves the issue but not totaly.

                              IndirectNormalInfluenceBoost Does not seams to affect this at all.



                              Uploaded with ImageShack.us



                              Uploaded with ImageShack.us

                              Comment

                              Working...
                              X