No announcement yet.

Scaleform UI breaks after recompile

  • Filter
  • Time
  • Show
Clear All
new posts

    Scaleform UI breaks after recompile

    When I started digging into the depths of the new scaleform front end I noticed that the back buttons would no longer work. I re-installed the whole UDK and the buttons worked again.

    I started fiddling and found that as soon as the .u files were re-created (For debug mode) the views no longer seemed to pop correctly off the stack.

    Has anyone else experienced this and do you know how to fix it?

    Trying to get a bit further with this, I found that the pop function is in a .as file, so set up my own copy of the menu system to experiment with.

    When I import however, I get the following message

    What part of the .fla file tells the main_menu to look for a udk_assets.swf file?

    Also the docs say that

    Logging from Scaleform GFx is turned on by default in the PC library, but not the console libraries. Logging is sent through the DevGFxUI logging channel, which is suppressed by default. To enable, comment out (using a semi-colon) the line "Suppress=_DevGFxUI_" in your game's Engine.ini file (e.g. GearEngine.ini).
    But I dont see any of the logging from the .as file appearing in the game logs, and I cant find that suppress line anywhere in the .inis.


      Found it (I think)


        Solved it

        The PopViewStub() function that epic supplies in the august udk was written incorrectly. A quick switch to make it actually do what it was supposed to and the menus started working again :P

        Also for anyone wondering about the logging, BaseEngine.ini has the following line


        rather than whats suggested in the docs. You can also remove Supress=DevUI to get more info on whats happening in the menus



          Im confused... What did you change in PopViewStub() ?


            Its a one line function that returns object. You don't want an object, you want a function to be called. I changed it to a function.