Announcement

Collapse
No announcement yet.

Few questions regarding view and models.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Few questions regarding view and models.

    Hello everyone. I've got a few questions regarding UDK. I'm really new to it, in fact I just started. I've been viewing the tutorials, and I completed the Simple Level one and was going on to the Top Down tutorial, but got stuck at the moving box creation. The reason is that the box wasn't actually in the content browser, so I had no idea how to select and add it in. I have the other sounds and such for all the videos leading up however.

    Another question I have is the player's view. Currently, I feel as if I am a midget in the world. Possibly this is due to the high walls I have built, however, it just feels wrong. Is there a way I can fix this to perhaps span the view higher, as in making myself see higher? I put a few barrels in the simple level, and I couldn't even see on top of them or jump on them without double jumping.

    I also would like to know how exactly to use 3D models in UDK. I am not a very creative guy, or good at modeling, so I've been browsing sites like TurboSquid and tried to find royalty free models that I could use for experimenting with. For instance, if I download this model from TS, how can I use it in game? I know it will not be able to roll and such and act like a car (I'm not sure how I would do that either), but for now I'd like to at least have it in game.

    That is all for the moment, though I perceive I'll have many more in the future. I've searched a bit, and didn't find anything on the view subject, and found a few things on the modeling subject that weren't clear to me. Thanks!

    #2
    Originally posted by Guitarrasdeamor View Post
    I've been viewing the tutorials, and I completed the Simple Level one and was going on to the Top Down tutorial, but got stuck at the moving box creation. The reason is that the box wasn't actually in the content browser, so I had no idea how to select and add it in.
    Did you download the assets .zip from this page?

    http://udn.epicgames.com/Three/Video...%20Using%20UDK

    It should have everything you need inside it. Just extract the contents into the Content folder (or a subfolder) in your UDK installation.

    Comment


      #3
      Originally posted by ffejnosliw View Post
      Did you download the assets .zip from this page?

      http://udn.epicgames.com/Three/Video...%20Using%20UDK

      It should have everything you need inside it. Just extract the contents into the Content folder (or a subfolder) in your UDK installation.
      I did download both and put them in the content folder actually, but for some reason the box didn't show up. I'll re-download both again, and then place them inside a new folder and see if that fixes it.

      Comment


        #4
        Make sure you don't have any filters set in the Content Browser or, if you do, they are the right filters to allow you to see the type of asset you are looking for. And make sure you find the package in the Packages list and select it so you are looking at the right package. There is definitely an SM_Block static mesh in the topdown_test package that is basically a box.

        Comment


          #5
          Yep, I re-added all the packages, and the block is still not there. Not sure what's up with it, but the block is not there. Only the key and the floor panel.

          EDIT: Well, yes and no. I decided to open the level that came with the pack (I opened it, but I also saved a copy of my own), and it shows up now. I'm guessing it is somehow set to only show with the specific level name. When I rename the level to the regular name, it shows up. However when I copy it and it renames it to a copy, it shows. Don't know what was up, but it seems to be fixed now.

          So, onto the other questions.

          Comment


            #6
            I have a new problem or two. I'm following the Topdown Tutorial, and while trying to get the bots to move, they don't. I've followed the tutorial, checked everything with the Redux level, and nothing. For some reason my bots just stand still. Another problem is that as soon as I start the game, I get a key in my inventory after about 3 seconds.

            What gives?

            Comment


              #7
              Any more help?

              Comment


                #8
                I pulled up a chair in 3dsMax that I made a while ago with a tutorial. I exported it as .ASE as I had seen somewhere, and it turns out I was able to import it into UDK. However, it gave me a few weird pop-ups while importing, and it turns up with no textures and I am able to walk through it, even though the beam from the link gun hits it.



                For reference, here is what it looks like in 3dsMax:



                And here is what it looks like in the Static Mesh Editor:

                Comment


                  #9
                  Let me see if I can help you out. First off as you see in the static mesh view, there's only the base texture applied, meaning you didn't already have one on it. However it looks like you applied a material to chair after you put it into the level. Could you post a screen shot of that material? Maybe the diffuse texture is too dark?

                  Also, not sure what level you're at, but you made sure to rebuild the lighting after you placed the object in the level? Sorry if you did already. Hope I can help!

                  John

                  Comment


                    #10
                    also if you can walk through the chair, double click it when placed in world and check that "Collision -> BlockAll" is selected from the dropdown menu, its also possible that your chairs collision has gone a bit "funny" so open it up in the static mesh editor (the thing from double click in the content browser, what you've got open in your screens) and check the collision options there (Auto_Convex collision or 26 DOP should be alright for a chair).

                    as to your bots not moving, you'd have to post a shot of your kismet setup for them, cos ive never bothered with the Tutorials otherwise i cant help =)

                    Comment


                      #11
                      Originally posted by Mr. Mellow View Post
                      Let me see if I can help you out. First off as you see in the static mesh view, there's only the base texture applied, meaning you didn't already have one on it. However it looks like you applied a material to chair after you put it into the level. Could you post a screen shot of that material? Maybe the diffuse texture is too dark?

                      Also, not sure what level you're at, but you made sure to rebuild the lighting after you placed the object in the level? Sorry if you did already. Hope I can help!

                      John
                      I didn't have a texture on it (at least I don't think). Yeah, I rebuilt the lighting and it showed up and all, but I just hadn't in that one.

                      Originally posted by Deliverance6 View Post
                      also if you can walk through the chair, double click it when placed in world and check that "Collision -> BlockAll" is selected from the dropdown menu, its also possible that your chairs collision has gone a bit "funny" so open it up in the static mesh editor (the thing from double click in the content browser, what you've got open in your screens) and check the collision options there (Auto_Convex collision or 26 DOP should be alright for a chair).

                      as to your bots not moving, you'd have to post a shot of your kismet setup for them, cos ive never bothered with the Tutorials otherwise i cant help =)
                      Blockall was the first thing I checked! Learned that from the tutorial. Then I decided to do your suggestion, so I booted up UDK and added the chair again, and these are the error messages I got:



                      1 and 2 were when importing the chair. 3 and 4 were when I put the chair in the level (after using Auto_Convex collision) and tried to press "Play from Here". Whether I pressed yes or no on 3, it led to 4. When the chair isn't there, it let me play like normal.



                      For the bots, here is a shot of the Kismet page:



                      Uploaded with ImageShack.us

                      Comment


                        #12
                        Originally posted by Guitarrasdeamor View Post
                        I didn't have a texture on it (at least I don't think). Yeah, I rebuilt the lighting and it showed up and all, but I just hadn't in that one.



                        Blockall was the first thing I checked! Learned that from the tutorial. Then I decided to do your suggestion, so I booted up UDK and added the chair again, and these are the error messages I got:



                        1 and 2 were when importing the chair. 3 and 4 were when I put the chair in the level (after using Auto_Convex collision) and tried to press "Play from Here". Whether I pressed yes or no on 3, it led to 4. When the chair isn't there, it let me play like normal.



                        For the bots, here is a shot of the Kismet page:



                        Uploaded with ImageShack.us
                        I can't answer ALL your question, I'm kinda new myself, but Ive come across some of these.

                        1. Not really important. But you could apply a material in 3dsmax before exporting, should resolve that.

                        2. I think this means that your model isn't completely composed of quads, which means you have more vertices then you would have if your model was all quads. Its not a big deal. Somebody correct me if I'm wrong on this.

                        3,4. Cant answer that.

                        With regards to the collisions. I think a simple 6DOP collision would be fine. Alternatively you can create a simplified copy of your model in max, make sure its the same name as the chair, but add UCX_ in front of it. When you export it and import into UDK, it will automatically use that UCX version of the model as a collision model for you.

                        Comment


                          #13
                          The black and wood looking textures I put on in 3dsMax were materials though. Not sure why they wouldn't carry over.

                          Comment

                          Working...
                          X