Announcement

Collapse
No announcement yet.

Speedtrees harsh shaddows - dynamic and static

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Speedtrees harsh shaddows - dynamic and static

    When I turn "Use Precomputed Shadows" it looks like the speedtree pops into dynamic lighting only. I have a dominant directional light that's lighting my level. It creates harsh shaddows.
    [SHOT]http://img175.imageshack.us/img175/5269/capturedk.jpg[/SHOT]

    I want it to cast its dynamic shadow, but be lit by all the point lights around it to remove the harsh shadows. How can I light it with the point lights but have it cast a dynamic shadow?

    #2
    Leave tree shadows as they are, and in dominant directional light check for option Whole Scene Dynamic Shadows (or something like that) right with cascade ligthing, and set it 1000 ormore.

    Comment


      #3
      There is Force Dynamic Light but it won't check and would force everything to be dynamically lit.

      More or less I'm asking how I can get the tree lit with static included but just cast the dynamic shadow.

      Comment


        #4
        No, don't check "force dynamic". Go to the dominant directional light's properties -> light -> light component -> CascadedShadowMaps and then increase the dynamic shadow radius. Tweak the settings to your liking.

        Comment


          #5
          That works great for trees that don't have there "use precomputed shadows" flag checked. Problem is I can't check the static channel in without it. I want it to be lit by static lightmass at least, but cast a dynamic shadow.

          This works fine if the tree is in dynamic, but if its in dynamic its not being lit staticly.

          I have another issue though, my dominant light is not lighting my scene. It affects my dynamic objects only, though it says its on the static channel too.

          (This is what my scene looks like after lightmass finishes with it. Its the only light in my scene and the only thing that lights up is one tree set to not use precomputed shadows.)
          [SHOT]http://img189.imageshack.us/img189/9887/capturesil.jpg[/SHOT]

          (Here you can see its on static)
          [SHOT]http://img176.imageshack.us/img176/932/capture2a.jpg[/SHOT]
          I've already checked UDN:
          http://udn.epicgames.com/Three/DominantLights.html

          Edit: I read the tool tip and I get what your saying, but here is a picture, the tree on the left is on the dynamic and static channels with use precompiled shadows on (you can't check static otherwise). The tree on the right has use precompiled shadows off and is only in the dynamic channel. The tree on the right has bright spots on top and is black on the bottom from the dynamic light that won't seem to light anything else. The tree on the left is lit by a pointlight nearby and after some tests I found its shadow comes from the pointlight nearby and (like the rest of the scene) is unaffected by the dominant light

          [SHOT]http://img267.imageshack.us/img267/1629/capture2yt.jpg[/SHOT]

          Edit2: I found that by going into world properties and "Open the lightmass/Lightmass settings tabs within and check "Use ambient occlusion"", I the level lights fine, though the quality of the shadows isn't as high as I'd like.

          Comment


            #6
            I made a workaround for this issue, since my trees are dynamic:

            Make a skylight with a very small value - mine is set @ .1, it has no directional control and you want to make sure to turn off 'affect composite shadow direction' and 'cast shadow', so that it does not mess with your light source. Then I also altered my shadow color for the DD light to not be solid black (shadows are never solid black in the real world).

            (Optional) I also took my bark material and multiplied its diffuse texture with a constant vector, with a value of .01, and plugged that into the emissive chanel. Even if some lighting does not reach an area, for example, underneath the foliage from any light, there would not be a surface that is completely black.

            Having tweaked these settings, I got a really good result for my scene.

            Hope it helps,
            Gera

            Comment


              #7
              Great! The skylight (though I liked its affect on some of my level, didn't affect the dynamic tree. I was going to try emissive and knew it would look fine when I changed the mod color on the Dominant light to a gray. Suddenly light was let through the trees and the tree lit up. The tree looks great and its shadows aren't black holes for light either. Looks great, thanks a ton!

              (open to other suggestions too, but I recommend you give this a try. )

              Comment


                #8
                Personally I wouldn't use a skylight. It just washes the colours out. Instead I'd use environmental lighting. Go to world properties -> lightmass and there set the environment colour to sky blue (or so). You can also tweak the intensity if you want.

                Comment


                  #9
                  Speedtree models have numerous issues with lighting vs Static Meshes, you're better of making your own model.
                  If you have 3DsMax, check AEC Extended primitives -> Foliage. That auto generates a decent tree trunk and branches, and then make the leaves yourself.

                  Also, Skylights are perfectly acceptable to use, throw them in another lighting channel and apply the trees in that lighting channel. If you would use the environment colour settings such as suggested above (would also be a solution, but) you would lose the darker ranges in places you would want them. Though a mix of the 2 is the best way to go.

                  Comment

                  Working...
                  X