Announcement

Collapse
No announcement yet.

Is there any way to disable the directx install for the package?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Use ModEditPackages and not EditPackages for your U file.

    Run the game in Cooked mode to get an accurate representation of how the package game plays. This is a flag in the Front End "Run as Cooked" or similar name.

    And note quotes and semicolon is ever required in the ini. Semicolon actually excludes things.

    Leave a comment:


  • replied
    Thanks RandomNinja for posting...

    I tried putting it in there... but no difference... It refuses to use my classes and my game... MyFolder.MyGame

    (again... it works fine in editor but not when game is packaged)

    Also... Do you know why that particular line requires quotes and a semicolon at end?

    I tried it with it and without it (I have noticed DefaultGameType sometimes there and sometimes not in other peoples DefaultGame.ini config file - and it always has the quotes and semicolon - but cannot figure why this line is different and not consistant formatting requiring quotes and semi colon) Or even if this line is necessary or not?

    Thanks

    Leave a comment:


  • replied
    In your DefaultGame.ini, try setting

    [Engine.GameInfo]
    DefaultGameType="YourGameFolder.YourGameInfoClass" ;

    And if you have a custom playercontroller class, also add:
    PlayerControllerClassName=YourGameFolder.YourPlaye rControllerClass

    You don't usually have to edit (as far as I know) your UT*.ini or UDK*.ini files, as they get generated from the default ones.

    Leave a comment:


  • replied
    Thank for responding guys!

    Here's the issue... Im testing "packaging" (more than usual I guess) because for some reason my classes are not getting used in the packaged version - but are getting used when running directly from editor using the "run from editor" button (but not when using the "run on pc" button from editor)

    I have changed the config files (UTEngine.ini and DefaultEngine.ini) with a "?game=MyFolder.MyGame" and it works fine from the editor...

    Code:
    InEditorGameURLOptions=?game=MyFolder.Mygame?quickstart=1?numplay=1
    But how do I get the game to DEFAULT to to run my classes (MyFolder.MyGame) when the game is packaged or using the run on PC button from editor?

    I already changed the UTGame and DefaultGame.ini files...

    Code:
    [Engine.GameInfo]
    DefaultGame=MyFolder.MyGame
    DefaultServerGame=MyFolder.MyGame
    Thanks
    Bill

    Leave a comment:


  • replied
    Yeah, you just rebuild your scripts (via frontend or by starting editor and hitting "yes" on rebuild scripts or via nFringe) and run it in the editor. Or rebuild and run your game exe.

    Or, if you use nFringe, you can run it directly from visual studio.

    If you're testing your game by packaging and installing it each time, then that sounds like a lot of work... :P

    Leave a comment:


  • replied
    I really dont package it that much... but it would still be nice not to have to wait for that if there was some way to turn it off for testing.

    Also... can I make changes to the script and code and not package the game - to see the changes from the editor?

    Thanks
    Bill

    Leave a comment:


  • replied
    Why would you do that?

    Just don't package your game all the time. Create it using the editor, test it in the editor, then export it when it's done...

    Leave a comment:


  • Is there any way to disable the directx install for the package?

    Is there any way to turn off the installation the prerequestites (directx, PhyX, etc.) - during the installation - everytime I test a new package it re-installs and is not necessary since It already is there. and it takes a long time

    Thanks
Working...
X