Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

how do you use bink in udk?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • how do you use bink in udk?

    how do you import and use bink video in the udk?
    i've seen them in the credits and all,but i haven't figured out how to import the bink file into udk.
    any help,i'd want to know exactly how to use it in the main menu or in a cutscene.

  • #2
    you can simply jjust import it, and it will show up then u just apply it to a bsp wall or something and it will play, if u need help i will make a test and send it to you

    EDIT: Yup it works just import the .bink or .bik video and create a material for it and connect it to diffuse and u can use it on walls or anything u want

    Comment


    • #3
      wow thanks thats pretty simple.
      how would you use that in a ui scene though?

      Comment


      • #4
        ok lemme give u a quick tut tell me if it works ima edit it in a couple minutes :]


        EDit: OK here we go in ur UI scene right click somewhere and select place widget> Image
        Then in the right ull see the properties of the image widget you can also stretch the widget to make the image fit the desired area by just click dragging one of the corners.

        with the image widget selected on the top right youll see properties look for "Components" tab >image component>style override and in "image ref" with the MOVIE TEXTURE selected not the material version you may have created earlier but the regular unedited MOVIE TEXTURE that u imported, so with that selected go back to "image ref" hit the green arrow pointing left and it should appear playing the vid :]

        Comment


        • #5
          let me try that out,thanks for the help.

          Comment


          • #6
            no prob

            Agent

            Comment


            • #7
              mmm, i don't undestand... i tryed that but i'm a newbie :S

              Can you post a video-tutorial or a images-step for see what you did?


              Tyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy


              EDIT: Ok, i have the UIScene object with the video working....but how can i insert this UIScene object into my map? i built a bsp square but i can't apply that uiscene...what did i wrong? tyyyy

              Comment


              • #8
                Any idea? :S

                Comment


                • #9
                  Originally posted by TheAgent View Post
                  ok lemme give u a quick tut tell me if it works ima edit it in a couple minutes :]


                  EDit: OK here we go in ur UI scene right click somewhere and select place widget> Image
                  Then in the right ull see the properties of the image widget you can also stretch the widget to make the image fit the desired area by just click dragging one of the corners.

                  with the image widget selected on the top right youll see properties look for "Components" tab >image component>style override and in "image ref" with the MOVIE TEXTURE selected not the material version you may have created earlier but the regular unedited MOVIE TEXTURE that u imported, so with that selected go back to "image ref" hit the green arrow pointing left and it should appear playing the vid :]
                  can you explain more detail about it?

                  Comment


                  • #10
                    hi all,

                    I managed to get the .bik file to load on startup cause it's a intro movie, but I have 2 problems :

                    1. The sound of the .bik does not play
                    2. The movie starts at a random place and loops, but when I uncheck the looping tickbox within the texturemovie the .bik no longer displays?

                    Any help or code that could help with the implementation of this would be greatly appreciated.

                    Thanks

                    Comment


                    • #11
                      Yep, same problem :S

                      Comment


                      • #12
                        1. sound will only play in game, not in the editor
                        2. you can trigger the bik to start in kismet
                        New Action > Cinematic > Control Movie Texture

                        Comment


                        • #13
                          I cant get the UI to stop automatically after the movie is done playing... I have plugged out int close scene, have also tried to plug a delay as well as plugging both success and failed into close scene...

                          EDIT: also no sound will play even though added in the sound tab in the proprieties

                          Comment


                          • #14
                            wow i can't believe this was brought back up lol,this was a long time ago.

                            Comment


                            • #15
                              This has had more than a few necros

                              Comment

                              Working...
                              X