No announcement yet.

(UDK 3) ESC key stopped working. Again. (edit: Solved)

  • Filter
  • Time
  • Show
Clear All
new posts

    (UDK 3) ESC key stopped working. Again. (edit: Solved)


    I have an annoying glitch for which I haven't been able to find an answer anywhere. I've been reading quite some posts and websites and tried a lot of things, but to no avail. Maybe it is just me, I don't know.

    Two weeks ago I bought a good PC and I installed UDK 3 to refresh my skills on game design. Everything was fine until the ESC button suddenly stopped working in game preview, you only could quit via the console or by hitting alt-tab to get the mouse back and close the window. This happened after making a minor change to an ini-file with Notepad, I hadn't touched anything else. I changed my change back, but that did not work. I tried to save the file with the FixedSys font, with different encodings, that did not work either. Eventually I ended up reinstalling UDK and everything was fine again. Until today. The ESC key stopped working again, but now I hadn't touched any ini-files. I did however download tutorial assets from the web yesterday, which were detected by UDK. Maybe UDK changed ini-files, I don't know, but since I had a copy of the original config folder from the fresh install I replaced the actual folder with the 'clean' one and started up UDK again. Too bad, ESC still didn't work.

    So i decided to install UDK again, but now to its default folders (and not under D:\Data\Apps\UDK). First run: ESC works fine. Closed down UDK, opened the keybindings.ini, added and removed a space, saved it, started UDK again: ESC not working anymore. Again. Reinstalled UDK: fine. Closed it down, opened the ini-file without wordwrap selected, didn't change a thing, just hit ctrl-s: ESC not working. Of course I tried to install and run UDK as administrator: no change.

    I am baffled. Is this a familiar problem? I am on Windows8.1 with UDK 64bit. The weird thing is that I have something similar with the old Unreal Tournament which I installed to see the old UnrealED on which I used to make levels a long time ago. To my surprise there are still UT servers online and playing some old maps was quite funny. However, one day everything worked fine, the next day ESC did not work anymore.

    I haven't encountered anything like this in other games and applications, ever. It makes no sense to me. To me it seems that as soon as UDK has encountered a 'touched' ini file the ESC stops working, no matter if the original folder with the original untouched files is restored. While writing this post I did a final test: fresh install, ESC works. Closed down UDK, restarted it without doing anything else: ESC not working anymore. Now I'm completely lost.

    If you know something, thank you very much in advance. I simply don't understand this and I am out of options. There are no warnings or errors, ESC simply stops working for any reason until UDK is reinstalled, which is very annoying. Other keys (as far as I know) work fine. I am sorry if this issue has been addressed elsewhere already, I simply have not found it then.