Announcement

Collapse
No announcement yet.

Materials issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Materials issue

    Hello,

    My name is Mike, I´m 24 years old and I´m new to UDK.

    I created a model in blender (I´m also pretty new to blender but at least I know the basics of this program) and imported its diffuse texture and normalmap to UDK to create a material out of them.

    The guy in the tutorial, I watched, did this by rightclicking on the diffuse texture in the Content Browser and then selecting "create new material", but this "create new material"-option doesn´t show up if I rightclick on my textures.

    Then I searched on the web and all sources, I found, said the same: Rightclick at an empty space in the Content Browser, select "New Material" and then either drag your textures from the Content Browser into the material editor of the empty material, you just created, or select a texture in the Content Browser and press "T" plus left mousebutton in the material editor.

    When I drag a texture into the material editor it just doesn´t do anything and if try the other option with "T" plus left mousebutton it just adds an empty Texture Sample although my texture in the Content Browser is selected.

    The size of my textures is 512x256. I also tried it with a 512x512 texture, because I thought it might has to be square, but this also didn´t work.

    I really don´t know what to do.

    Thanks in advance for your help.

    Edit: Problem solved! I noticed, that creating materials works for UDK´s own textures, so I knew something is wrong with my files. I changed the file format from jpg to tga and now everything works fine.

    #2
    For what it's worth, you should save all your GAME development textures as either .TGA or .PNG type files. These seem to be the most common ones in use other than perhaps the .PSD format.

    Comment

    Working...
    X