Announcement

Collapse
No announcement yet.

UDK game/editor exits after splash screen on DX9 system

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK game/editor exits after splash screen on DX9 system

    I'm trying to work on my project on a Win8 machine that has a Geforce 330M which isn't DX11 compatible.

    My project was originally on my other DX11 machine and when I copied it over, it's stuck launching in DX11 mode. The splash screen says like (32bit, DX11). I can't find any way to force it to launch in DX9 mode. I tried AllowD3DX11=False in the DefaultSystemSettings.ini with no effect. There seems to be no -dx9 or -d3dx9 command line parameter that would help.

    I tried launching a sample project installation and it worked fine. Then I switched to DX11 renderer in the editor just to see what would happen and now the sample project also fails to launch. Weird thing is, the splash screen says (32bit, DX9) on startup, so even though it's launching in DX9 mode it still seems fail after running in DX11 mode even once. I can't even find any setting in the ini files anywhere related to DX11.

    After looking in logs, it's saying
    Found D3D11 adapter 1: Microsoft Basic Render Driver
    Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory

    I looked up how Win8 has some fallback DX11 display that does nothing so maybe UDK needs to handle that and not consider that device as a valid rendering device? http://msdn.microsoft.com/en-us/libr...(v=vs.85).aspx

    Here is my log when it fails to open any project. It just randomly shuts down after it's done initializing FaceFX.
    Code:
    Log: Log file open, 12/29/13 09:17:16
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    DevConfig: GConfig::Find has loaded file:  ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 10907
    Init: Epic Internal: 0
    Init: Compiled (32-bit): Jul  1 2013 15:00:14
    Init: Changelist: 1715227
    Init: Command line: editor
    Init: Base directory: E:\Resources\UDK\Sample\Binaries\Win32\
    [0000.63] Init: Computer: ILLLAPTOP
    [0000.63] Init: User: isele000
    [0000.63] Init: CPU Page size=4096, Processors=8
    [0000.63] Init: High frequency timer resolution =1.562557 MHz
    [0000.63] Init: Memory total: Physical=3.9GB (4GB approx) Pagefile=8.7GB Virtual=4.0GB
    [0000.63] Log: Steam Client API Disabled!
    [0000.67] Init: WinSock: I am illLaptop (192.168.1.19:0)
    [0000.67] Init: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
    [0000.67] Init: Object subsystem initialized
    [0000.70] Log: SystemSettings based on: SystemSettings
    [0000.72] Log: Found D3D11 adapter 1: Microsoft Basic Render Driver
    [0000.72] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory
    [0000.72] Log: Shader platform (RHI): PC-D3D-SM3
    [0000.99] Log: PhysX GPU Support: DISABLED
    [0001.00] Init: Initializing FaceFX...
    [0001.00] Init: FaceFX 1.7.4 initialized.
    [0002.33] Exit: Preparing to exit.
    [0002.33] Exit: Object subsystem successfully closed.
    [0002.33] Log: Shutting down FaceFX...
    [0002.34] Log: FaceFX shutdown.
    [0002.35] Exit: Exiting.
    [0002.35] Log: Log file closed, 12/29/13 09:17:18
    Here is my log when it successfully launched the sample project:
    Code:
    Log: Log file open, 12/27/13 18:11:47
    Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
    DevConfig: GConfig::Find has loaded file:  ..\..\Engine\Config\ConsoleVariables.ini
    Init: Version: 10907
    Init: Epic Internal: 0
    Init: Compiled (32-bit): Jul  1 2013 15:00:14
    Init: Changelist: 1715227
    Init: Command line: editor
    Init: Base directory: E:\Resources\UDK\Sample\Binaries\Win32\
    [0000.73] Log: Deleting old log file Launch-backup-2013.12.04-22.55.40.log
    [0000.76] Log: Deleting old log file Launch-backup-2013.12.04-22.58.52.log
    [0000.76] Log: Deleting old log file Launch-backup-2013.12.04-23.05.10.log
    [0000.76] Log: Deleting old log file Launch-backup-2013.12.27-18.11.47.log
    [0000.76] Init: Computer: ILLLAPTOP
    [0000.76] Init: User: isele000
    [0000.76] Init: CPU Page size=4096, Processors=8
    [0000.76] Init: High frequency timer resolution =1.562554 MHz
    [0000.76] Init: Memory total: Physical=3.9GB (4GB approx) Pagefile=8.7GB Virtual=4.0GB
    [0000.76] Log: Steam Client API Disabled!
    [0000.83] Init: WinSock: I am illLaptop (127.0.0.1:0)
    [0000.83] Init: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
    [0000.83] Init: Object subsystem initialized
    [0000.86] Log: Last hardware survey: Ver=10907, Date=20131205. Uploading again.
    [0002.80] Log: Failed to upload UDK hardware survey to http://et.epicgames.com/PostUDKSurveyHandler.ashx in 1.50 seconds.
    [0002.80] Log: SystemSettings based on: SystemSettings
    [0002.83] Log: Found D3D11 adapter 1: Microsoft Basic Render Driver
    [0002.83] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory
    [0002.84] Log: Shader platform (RHI): PC-D3D-SM3
    [0012.61] Log: PhysX GPU Support: DISABLED
    [0012.85] Init: Initializing FaceFX...
    [0012.87] Init: FaceFX 1.7.4 initialized.
    [0034.69] Init: Finished loading startup packages in 13.87 seconds
    [0034.70] Log: 82464 objects as part of root set at end of initial load.
    [0034.70] Log: 0 out of 0 bytes used by permanent object pool.
    [0035.28] Log: Supported Consoles:
    [0035.28] Log:   IPhone
    [0035.28] Log:   Mac
    [0035.28] Log:   PC
    [0035.28] Log: Initializing Engine...
    [0035.54] Log: Encountered missing default brush - spawning new one
    [0035.54] Init: UEngine initialized
    [0035.54] Log: Primary PhysX scene will be in software.
    [0035.54] Log: Creating Primary PhysX Scene.
    [0035.56] Init: Transaction tracking system initialized
    [0035.62] Log: Can't find edit package 'OnlineSubsystemGameSpy'
    [0035.63] Log: Can't find edit package 'OnlineSubsystemLive'
    [0041.46] Init: XAudio2 using 'Speakers (High Definition Audio Device)' : 2 channels at 44.1 kHz using 16 bits per sample (channel mask 0x3)
    [0041.59] Init: XAudio2Device initialized.
    [0041.63] Init: Client initialized
    [0041.63] Init: Editor engine initialized
    [0042.23] Log: Initializing Engine Completed
    [0042.23] Log: >>>>>>>>>>>>>> Initial startup: 42.23s <<<<<<<<<<<<<<<
    [0042.55] Cmd: MODE MAPEXT=udk
    [0042.89] SourceControl: Source Control disabled in UDKEditorUserSettings.ini.  [SourceControl] has Disabled=True
    [0045.67] Log: Found D3D11 adapter 1: Microsoft Basic Render Driver
    [0045.67] Log: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory
    [0049.37] Cmd: MAP LOAD FILE="..\..\Engine\Content\Maps\Templates\Template_MidDay.umap" TEMPLATE=0
    [0049.71] Log: Encountered missing default brush - spawning new one
    [0050.07] Log: New File, Existing Package (Package Untitled_2, Package template_midday)
    [0050.39] Log: -- Checking Building LODs
    [0050.39] Log: Primary PhysX scene will be in software.
    [0050.39] Log: Creating Primary PhysX Scene.
    [0050.40] Log: Finished looking for orphan Actors (0.003 secs)
    [0050.40] Cmd: MAP CHECKDEP DONTCLEARMESSAGES DONTDOSLOWREFCHECK
    [0050.41] Log: TIMER ALL OF INIT : [37.526877]
    [0059.73] Exit: Preparing to exit.
    [0059.99] Exit: Editor shut down
    [0059.99] Exit: Transaction tracking system shut down
    [0060.14] Exit: Windows client shut down
    [0060.14] Exit: XAudio2 Device shut down.
    [0060.21] Exit: Object subsystem successfully closed.
    [0060.22] Log: Shutting down FaceFX...
    [0060.22] Log: FaceFX shutdown.
    [0060.27] Exit: Exiting.
    [0060.27] Log: Log file closed, 12/27/13 18:12:46
Working...
X