Announcement

Collapse
No announcement yet.

Cannot move in map...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot move in map...

    Hey guys, sorry if this topic has been created before.

    I have recently come across an issue that had never existed for me before. My Portfolio map created for college is having an issue once I spawn the player, either in the viewport or otherwise, whether or not I use the player spawn or "play from here" option.

    Long story short, I haven't touched this map since I graduated but back then it was working fine, player spawn was working, camera was fine, etc. and I was able to show it off flawlessly at the portfolio show. Recently however, I wanted to show it to a buddy to explain some things to him and that's when the issue started happening.

    Basically, as I said, nothing has changed in the map as I hadn't touched it since back when it was working fine - so there is no geometry blocking the character, no spawning below the map, or anything of the like. For some reason though, whenever I spawn into the map by any means (player spawn, play from here, etc.) I simply cannot move, look around or fire the weapon (gametype is set to UTGame). I've tried changing the game type, no bueno. I've tried uninstalling and reinstalling UDK, both the original files uninstall which didn't work, and the full uninstall (including user-created stuff, since everything is saved in a .udk map anyway I wouldn't lose anything) which also didn't work.

    The odd thing is that I can still scroll through my weapons with the mouse wheel (default link gun and unarmed), and once in a while depending on the game type I can (sort of) jump, but it's like a half jump.

    I brought up the console and tried Fly, still can't move. But when I use Walk, I am able to walk around the level again as well as look around, but I still can't fire my weapon. I've also tried dying and respawning, still can't fire the gun.

    I also tried deleting the player start which didn't help either. Same with rebuilding the map.

    So TL;DR when I spawn into my map (player spawn or play from here), I can't move, look around or shoot but I can switch weapons. If I type Walk into the console, I can move around and jump normally but still can't shoot. Deleting player start or rebuilding map doesn't help. Uninstalling (full or original files) doesn't help. Used to work absolutely fine before, and I haven't touched or changed anything since, so there's no collision blockage nor am I spawning beneath the map or inside an object, as I wasn't before back when the map worked flawlessly - so this issue simply recently popped up out of nowhere.

    Hopefully I can get some help with this as a google search only revealed two threads with similar issues, one of which had no answer and the other stating that Uninstalling/Reinstalling fixed it, which I tried to no avail.

    #2
    Move your whole map a little bit up and then try it again. Now immediately after you have spawned, you have to jump. Probably it works now

    -are you 100% sure that your collisions are fine?
    -what is included in the map? e.g landscape,...
    -try to spawn a bot and see what he does

    Comment


      #3
      I've tried all that, and yes I am 100% certain that the collisions are fine. As I stated in the OP, the map was working perfectly before. I changed absolutely nothing in it, I just reopened the map today and the issue is happening. No changes whatsoever other than this odd issue.

      No usage of landscape, everything is static meshes with either blocking volumes or normal collision applied. It's a complete scene, with lights and everything, animated materials, so on and so forth - it was a college graduation portfolio show piece so it's pretty full and complete, and it had to have no issues or I would probably still be a senior there, heh. No BSP usage or anything of the like - it's simple but doesn't look it, and very very organized.

      I've even moved one of my rock meshes up in the air and spawned on top of it (play from here), something I've done before so that I could jump into the water in my map from REEEEEEEEEEALLY high just for fun, and the issue persists. I can't move until I type Walk into the console (after which I move normally, can double jump, bounce off objects, etc.), and even after that the weapon simply doesn't fire (which wouldn't happen even if it WAS a collision issue, so it's definitely a bug or some setting that reset itself or something).

      EDIT: Spawned a bot with a path, he moves fine. I still can't...

      Comment


        #4
        Try this:

        Open a blank or template map - now stream your map into this level (e.g http://www.youtube.com/watch?v=MAKzeAFArt0 of course without the kismet stuff ;D)

        Comment


          #5
          Thanks for your replies.

          I have a camera in the scene that uses Kismet already for a flythrough.

          What would streaming my map accomplish though? ATM I don't have any recording software, and if I remember correctly I don't think FRAPS or anything like that works with UDKs overlay (tried using it to record my flythrough for school a while back). I am pretty certain I have the flythrough video still though if you really want to see the map.

          I forgot to mention I did try it in a new blank map and it worked fine. So I really don't understand why it suddenly, with no changes made to the map, stopped working on it. Even completely deleting all player start associated stuff, as well as changing the game type, didn't help.

          EDIT ::: Ah sorry, I misunderstood what you meant by streaming. You meant I should load my level into a blank map, I assumed you meant streaming as in recording it live or just recording in general. My mistake I'll give that a try. That's a TON of assets coming into the new level though but maybe it'll work.

          EDIT 2 ::: I have an error saying:
          "Importing external sublevels is not allowed. Move the level files into the standard content directory and try again.
          After moving the level(s), restart the editor."

          I'm (perhaps wrongly) assuming it's because I don't have my map saved as a .upk/package, it's a .udk map using external package references so that I could keep it all organized easier using Maya's file setup and adding a UDK folder to my maya file's directory (talking about the folder group created when I saved my maya file that contains all of the original assets - in other words I have Scenes, Source Images, Textures, "UDK" [contains my .udk as well as my .ase assets], ZBrush, etc. as subfolders within my main folder for my Maya scene), so that I can keep everything together - I try to be as organized as possible because it just makes everything easier and break a LOT less. Oddly though, the video shows him saving his tests as .udk files anyway, but all he created was a landscape so I'm unsure what's up with mine in that regard.

          Anyway concerning spawning, this was never a problem before (using externals), and though I would get the "External Reference" warning when I would play the level, it still allowed me to do anything I wanted beforehand as it was a non-issue. So I'm not sure why the issue would suddenly pop up out of nowhere now with no changes made to the map itself. I was even able to frontend the map and send the exe to people, and it would still work fine. Probably still can, though I haven't tested it - though the issue with being unable to move and shoot may persist.

          Sorry to sound repetitive with this, but basically chronology is thus:
          -Created all assets, made the map and a flythrough, etc.
          -Showed my map at the port show, was able to play from here or just play map and start at the player-start, both worked with no issue - it would then play my flythrough, and then spawn me able to run around, shoot, swim in the water (low grav volume), etc. everything worked like it should.
          -Graduated college, haven't touched map since.
          -Opened map today, play from here, flythrough did its thing as normal and all working fine so far, then spawned but unable to move or shoot unlike before.

          Comment


            #6
            I managed to get my level to stream into a new blank map. I had to load my level, then load a blank map without saving my level, then Content Browser -> Levels etc. etc. in order to not get that error I previously posted about.

            After I did so, my kismet stuff didn't transfer over, and I couldn't spawn at all - everything was just black even after rebuilding all. I could see it when in the editor, but not when spawning in. Not sure what's up.

            Any other solutions? Is there a way to maybe reset all options when it comes to movement controls and such? Maybe a hidden folder to delete once I uninstall to ensure a FULL uninstall/reinstall? I'll dig around and see what's up...I can't really think of anything else.

            Comment

            Working...
            X