Announcement

Collapse
No announcement yet.

Transparency Issues?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Transparency Issues?

    Hi


    "vertex shader uses too many registers for shader model 3.0

    What is strange about this is that I can use this exact same material in any other build of UDK. it only gives me this in the July 2013 build. and what is brutal about this is the amount of hours I got into this build I really don't have time to redo the work in an older UDK version just so my game can have glass windows.

    I have done many attempts to fix, have reinstalled udk and I now have many variations of this material with various textures. I tried using a textures with an alpha, I unhooked the specular (In fact this material started with a normal map too)
    Anyway I at one point re-installed udk and created just this material alone with nothing else custom in the content browser and still this odd shader model error thing.
    anyway I can switch up the lighting model to like Unlit but that kills the Spec and that sucks.

    anyway the reason I put this in the issues category is because this material works in other udk builds. Maybe there is a better way to do this material I am unaware of.

    Thanks for reading.

    #2
    What sucks is that as old as this post is. I'm still having this problem.

    Comment


      #3
      works fine for me.
      this is on the 2014-08 version but I'm sure this has always worked for me in every other version I've tried
      Click image for larger version

Name:	window.jpg
Views:	1
Size:	9.1 KB
ID:	3250990

      edit: the forum upload sucks. here, http://postimg.org/image/n5spo95x9/


      I do see you have 39 instructions while I have 37. did you change any other material properties other than what's visible?

      Comment


        #4
        I did the test too in my 2013-02 and i have 39 instructions like him but mine works with no problem.Just change your version i supose.

        Comment


          #5
          Yes I find it works in 2012 versions anything newer I get error. thanks for responses.

          Comment

          Working...
          X