Announcement

Collapse
No announcement yet.

Cannot select packages in Content Browser

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot select packages in Content Browser

    Hi,
    I have an issue where I cannot select packages in the Content Browser. Or rather, it takes a minute. Literally, a whole minute before it refreshes and selects the thing. Every time I select something. I can work around this issue by deleting all of my auto-generated ini files (any UDK*.ini file in UDKGame->Config). But I have to do it every time I run the editor. I've used Unreal 3 since 2005 so I'd like to think I'm pretty savvy, but I have no idea what could be causing this. I've tried it with multiple UDK versions. When I delete those auto-generated ini's UDK runs like a champ and I have zero performance issues.

    I'm pretty sure it has to do with my Laptop, because it doesn't happen when I'm on my desktop. I have an Nvidia GTX 670MX card in my laptop, but it also has an onboard Intel 4000. There's some thingy that switches it on the fly based on 3D needs. But it's just weird that it'll work just fine with those ini's deleted. I've already contacted my PC manufacturer (Digital Storm), but they don't know what's up. Any help is great appreciated!

    #2
    Well, you can try to
    Defragment your main disk. Also, they aren't deleted, they are recreated when running UDK, also sometimes when you want to start udk, a dialog box appears if you want to check new content, use it. Or, if it doesn't appear, use a commandlet to trigger it mannually(if you don't know it, it's included in unreal X-editor

    Comment


      #3
      Sounds like a performance issue. Is there space on your hard-drive and do you have more ram available?

      Comment


        #4
        Originally posted by Graylord View Post
        Sounds like a performance issue. Is there space on your hard-drive and do you have more ram available?
        I have tons of HD space and 16GB of ram.

        Comment


          #5
          Originally posted by cube2222 View Post
          Well, you can try to
          Defragment your main disk. Also, they aren't deleted, they are recreated when running UDK, also sometimes when you want to start udk, a dialog box appears if you want to check new content, use it. Or, if it doesn't appear, use a commandlet to trigger it mannually(if you don't know it, it's included in unreal X-editor
          I know that the inis are created every time I run. If I don't delete them before launching the editor i experience my issue. I'll try triggering that dialog in the X-editor and see if it helps. Thanks!

          Comment


            #6
            Originally posted by charliethetall View Post
            I'm pretty sure it has to do with my Laptop, because it doesn't happen when I'm on my desktop. I have an Nvidia GTX 670MX card in my laptop, but it also has an onboard Intel 4000. There's some thingy that switches it on the fly based on 3D needs. But it's just weird that it'll work just fine with those ini's deleted. I've already contacted my PC manufacturer (Digital Storm), but they don't know what's up. Any help is great appreciated!
            Go into the nvidia controle pannel and under 3d settings you can either choose "automatic" or "high-performance processor" (I dont know if its called like that, because my pc is on german). Now choose the hight performance. Then go into the power options and choose "high performance". Now it should work

            Comment


              #7
              Originally posted by fighter5347 View Post
              Go into the nvidia controle pannel and under 3d settings you can either choose "automatic" or "high-performance processor" (I dont know if its called like that, because my pc is on german). Now choose the hight performance. Then go into the power options and choose "high performance". Now it should work
              I tried this. The performance was already set to use the High-performance NVIDIA Processor. In fact its set both for the program and globally. I'm still having the issue. It's pretty annoying, but not stopping me from working. It just adds more clicking. I'm thinking about just writing a batch file that deletes those files before launching the editor. Hopefully I can find a resolution soon :-\

              Comment


                #8
                Thanks for everyone's help btw. I don't mean to just complain. I am appreciative :-)

                Comment


                  #9
                  One thing that I just thought of. Could this issue be caused by Environment Variables?

                  So I have several installations of UDK. Some I have installed directly onto this PC and others I have just copied over from another PC. Could this cause confusion with UDK? I always open up the Editor from the Unreal Frontend.

                  Comment


                    #10
                    This shouldnt cause any problems, because I have also done this and its working ^^

                    Comment


                      #11
                      Yeah, I've don it before in the past too. In fact I can't remember a time when I didn't have like a dozen UDK projects on one machine. But this is the first time I've moved entire projects from one machine to another.

                      I dug into my environment variables and there's nothing there. Which makes me think that it might be a registry issue...

                      One thing that I noticed in the past when I had multiple UDK projects, was that when I ran the editor for a copied project (as opposed to proper installation) I ALWAYS got the prompt to check the asset thingy. But I never get that now.

                      Comment


                        #12
                        I'm still having this problem. I have no idea what's causing it. It seems to now be intermittent. I looked into the Wait Chain When UDK isn't responding (ie every time I click something in the Content Browser). This is what the wait chain looks like when it's hanging.

                        Comment

                        Working...
                        X