Announcement

Collapse
No announcement yet.

Gradually degrading performance [possible memory leak?]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Just to be on the safe side - you're not talking about this:
    At a quick glance, these were the issues tackled:
    -Resolved the streaming memory leak issue.
    But about the issues with multi-core CPUs (which I was describing in detail above), right?

    If that is so, I'll see what can be done to animate the game's developers to put this onto their lists for future patches.

    Thanks again.

    Leave a comment:


  • replied
    The new UDK patch fixed it. But the games made with older versions, will still have the issue propably.

    Leave a comment:


  • replied
    I finally found a working solution for the issue, and apparently, it's not a memory leak. The Unreal Engine seems to struggle badly with certain multi-core CPUs (such as mine), thus producing the described symptoms. If the affinity is manually set to just the first core only, the issue disappears.

    Again, this only happens for me in games based on UE3, so the developers might want to look into this and see if there are any discrepancies regarding multithreading/multi-core CPU handling (especially aimed at AMD processors since this is what I got; updated the post on the 2k forums which I linked above accordingly).

    On my rig, this issue is reproducable at any given time. I'm glad I don't have to worry about it anymore, it was game breaking.

    Thanks for hearing me out.

    Leave a comment:


  • replied
    Fixed, at least release notes say that.

    Leave a comment:


  • replied
    Since I'm only playing games based on this (and not using UDK as a developer myself), I'm not really able to check right now. But thank you very much for the info.

    Leave a comment:


  • replied
    Well, new udk version out today. You can check whether it's fixed :P

    Leave a comment:


  • replied
    Well, I thought of that, too. Strange thing is though, that the issue I described also happens when no new data (be it from level, NPC, whatsoever) is loaded. Meaning: you can start up a new game, sit there in your starting area and wait for certain amounts of time. If you happen to be one of the unlucky people who is affected, your performance will drop.

    I read that changing levels (and thus loading more data into the RAM frequently) does speed this process up, but still, even without any loading it happens.

    I watched my RAM, I got 16 GiB of physical memory and it never reaches a cap where it would run THAT low to have such a heavy impact on the game. But then again, are UDK/UE3-based game executables even able to use that much memory? Maybe it's capped somewhere else (I read something about 32bit applications only having a maximum address space of 4 GiB if some "large address aware" flag is set), and once it reaches 4 GiB it hits the ceiling.

    But wouldn't the game crash at that point? For me, it just keeps on going, but with horrible audio-visual and input lag.

    Another thing which comes to my mind - if this bug/leak would be true for anyone who uses UDK or a game based on that engine, wouldn't that mean, anyone playing the mentioned games would have this problem? How come only a small amount of people seem to encounter this? My best guess would be, UE3 has some poorly written code targetting some very specific hardware components. Maybe it hates 100%-AMD-systems or something like that, and if your rig happens to fit into the picture, you're screwed like me. :/

    (for my full system specs you may check the quoted post from above)

    Leave a comment:


  • replied
    Try to watch your RAM. Maybe it can be somehow connected with huge memory leak in last UDKs (It will be fixed in upcoming beta).

    Doesn't leak
    2011-05

    Does leak (older versions are not tested)
    2012-05 - till now

    http://forums.epicgames.com/threads/...ht=memory+leak

    Leave a comment:


  • Gradually degrading performance [possible memory leak?]

    Hi there Epic Games dudes,

    I'm posting this into the UDK forums because of a simple reason: the following problem/bug/issue which I am going to describe in detail applies to ANY game/product created with (a certain version of) UDK and/or the Unreal Engine 3.

    I'm well aware that Epic Games will not (or cannot) offer support for specific game related questions in many cases, but since I strongly believe this is engine related, I'll try my luck here.

    Please let me quote my initial post from the BioShock Infinite technical support forum (BS:I was created with UE3):

     
    Spoiler


    The whole conversation can be followed here:
    http://forums.2kgames.com/showthread...ng-performance

    As you can see, I'm totally helpless with this issue. It does occur once in a while for other people, too - if you google specific phrases (describing the exact problem) you'll find a couple of posts on different game forums, but there's never any working solution (sometimes not even any reply at all).

    An interesting fact might be, that this only occured for me in games AFTER (or around) the release of XCOM/Dishonored (which were released in the same week iirc), so it may or may not be tied to a version of UDK/UE3 past that date.

    If anyone has insight or clues to this, I'd be most thankful.

    /edit
    There's a video showcasing the exact behavior of this issue, here:
    http://www.youtube.com/watch?v=g2zzouC0V1E

    Please skip directly to 08:26 and don't mind the rest of the video. You'll see what I'm talking about.
    Thanks
Working...
X