No announcement yet.

[SOLVED] Mobile viewer crash

  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] Mobile viewer crash


    I'm now in my 4th day of trying to track down the only crash I have in my app (which has been extremely difficult without source level access, symbol files or a decent debugger).
    The problem seems to be restricted to the PC mobile viewer crashing only & it doesn't happen on the actual iDevice itself. (Which is good, but very inconvenient).
    Using nFringe & log output has proven to be useless to get to the bottom of it - as I don't think the crash occurs in script code.

    Rather than post up a lot of code; the general description of what I'm doing is:
    I derive my own pawn base class from GamePawn which DOES NOT have a Mesh SkeletalMeshComponent, but rather has two StaticMeshComponents attached instead with a DynamicLightEnvironmentComponent
    I derive my own controller class from AIController

    From my base classes, I have several other derived classes that only modify the staticmesh assigned to the StaticMeshComponents

    When I dynamically spawn in game (cycling through which pawn to spawn) - the pawn will render properly for 2-3 frames and then crash with no information as to what's going on ( I have stepped through this in the debugger).
    Sometimes, I can successfully spawn dozens of these without incident.
    Sometimes it will fail at the same spot for the same type of pawn - but if I change to spawn just that pawn - it can work fine.
    My first thought was an uninitialised variable (I can't find any) or a problem with the renderer not handling dynamic pawn creation well for meshes that have 1200+ verts & 1600+ polys ???

    I have tried MANY permutations to track this down:
    Using a SkeletalMeshComponent & attaching, using 1 attachment, using 2 attachments, removing the lights, etc, etc - still crashes.
    Stripping everything down to a test pawn & controller - which works consistently with 1 mesh set - but can crash consistently with another (higher poly count)

    I actually have a fully working "mirrored" setup for a different set of pawn classes that works perfectly the way I expect; doing the same kind of stuff (lower poly)

    So, I'm kind of left thinking it's a bug in the engine with the meshes I'm trying to use ??

    I've looked at the DMP file in WinDB & Dumpchk, but without symbol info - I can't get anywhere.

    If someone could take a quick look at it (I'm using Feb 2013 UDK) & see if any information leaps out I'd be very grateful.
    The forum doesn't allow posting of anything other than (gif, jpg or txt files) - so I can't attach the dmp file.


    Not entirely sure what change I made got this working - but it seems ok for now at least.


    I think it was fixed by either one of the following:
    Remove fog for the PC materials involved AND/OR
    Make sure bCanBecomeDynamic is enabled on the static meshes invloved