Announcement

Collapse
No announcement yet.

Light Environment Component Magically Disabling

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Okay, so after hours and hours of flipping switches, clearing all my lighting and tweaking materials and actor properties. I've discovered that apparently, light environment components + static lighting channels and/or pre-computed shadows don't like each other.

    This would have been MUCH easier to debug if the editor didn't allow both incompatible options to be set and even go so far as to work as desired for a short time before breaking.

    It would have been really really nice to have been greeted by a disabled uneditable checkbox on the light environment when at some point I carelessly marked the static lighting channel rather than having the editor allow me to check the box, then proceed to work as I had expected it to for quite some time before just randomly unchecking the option in the background without any notice or announcement of any kind. The delay in manifestation of the error made it incredibly difficult to assert what went wrong. I was lucky to even notice that the light environment component "Enabled" checkbox had been unchecked to begin with because why would I expect it to have been.

    So if any developers out there ever read this... please fix this bug

    Leave a comment:


  • started a topic Light Environment Component Magically Disabling

    Light Environment Component Magically Disabling

    So I've been battling this for a couple days now and can't find anything on the forums so i'm hoping someone can help.

    1. View Actor Properties on selected IterpActors
    2. Enable Light Environment Component
    3. Everything appears to work
    4. save map
    5. close udk, or inspect some other actor or pretty much just do anything for a while.. sometimes i don't even have to do anything other than re-open the actor properties window for the selected actors..
    6. light environment component is disabled....


    At first I thought that maybe it was an incompatibility with some other option like that the dynamic light channel was checked, or that cast dynamic shadows was enabled or that accept dynamic lights was set as modifying those seemed to make things work temporarily, but after a close and re-open of the udk, all interp actors had their light environments disabled again.

    I do have several of these interp actors in the map. There are about 100 or so, and it seems like maybe it happens a lot after I re-enable one large group that another large group will be disabled but at this point i really have no idea.

    Are there any known lighting options on an interpactor that will cause the light environment box to just self disable with no error or any bit of useful explanation...?
Working...
X