Announcement

Collapse
No announcement yet.

UDK Installation Error - Shader Model 3.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Installation Error - Shader Model 3.0

    Greetings community,
    Sorry for posting such boring matters on the boards, but I am unable to install the UDK on my Home Desktop.
    Every time I double click the installer I get a "Your video card doesn't support shader model 3.0" error, and the installer exists.
    My setup is an i7 920 with an AMD HD5870. My drivers are Catalyst 13.1, latest ones as far as I know, freshly re-installed.

    Does anyone know anything about such issues? I would highly appreciate some insight on this.

    Good Day

    #2
    Hmm, your GFX card should support it plenty.
    All I can say is, make sure you are absolutely certain you have the latest official drivers and have restarted your PC, and that your download isn't corrupt.

    Comment


      #3
      Considering an AMD HD 5870 was ATI/AMD's first/original top-end DX11 card, it should have no problems whatsoever supporting Shader Model 3. DX11 works with Shader Model 5. UDK really shouldn't be having any problem with that card, period. Especially since I was able to get UDK to run decent when I had a HD 5770.

      Check and make sure you didn't install Windows Update KB2670838. According to Google and a different thread on this forum, that update has been causing all kinds of trouble.

      Comment


        #4
        I'd also check that you're actually using the dedicated card and not an onboard!

        Comment


          #5
          Thank you for your replies!
          Unfortunately I still haven't gotten UDK to work on my PC in spite of numerous re-downloads of the installer and performing a clean re-install with the latest official GPU drivers.
          Regarding Windows Update KB2670838, my Windows Updates have been turned off since ... 2011, mostly because I trust the stability of my system as is. Windows Updates have proven to not like me all that much in the past.

          Could the lack of performing any Windows Updates in the past two years be a cause for this?
          Also I am certain my system is running on the HD 5870. Sadly that's not it either.

          Fortunately it runs perfectly fine on my Laptop (GT640M GPU), but I'd very much enjoy being to work in UDK on my Desktop Computer.
          If any further readers have any ideas I'd very much appreciate it.

          Have a good day!

          Comment


            #6
            Originally posted by ambershee View Post
            I'd also check that you're actually using the dedicated card and not an onboard!
            I also think thats the problem. But I cant say you how to change this, because I dont have a AMD card.

            Also check if your card supports shader 3.0

            Comment


              #7
              I wanted to start UDK... fresh nooby here so please don't kill me

              My Problem is exactly this. Getting this message about shader model 3 while I think that an Ati Radeon 7950 OC officially support SM 5.0. I reinstalled drivers,.

              I'm using windows 8 64 pro

              Comment


                #8
                Still no answer?

                Comment


                  #9
                  Check the md5 of the installer and install all software on http://forums.epicgames.com/threads/...roubleshooting
                  Running the installer as admin or on a new account may fix the error

                  Comment


                    #10
                    It did, I downloaded the whole thing again and it works like a charm!

                    So the solution is to make sure your download is good

                    Comment

                    Working...
                    X