No announcement yet.

Multiple Dominant Directional Lights Error

  • Filter
  • Time
  • Show
Clear All
new posts

    Multiple Dominant Directional Lights Error


    I think I may have found an issue with the last few UDK builds. When using an archetype of a DominantDirectionalLight, or copying any sort of DDL from another map into a brand new map, the error check shows this:

    Error Untitled_14 DominantDirectionalLight_0 Multiple DominantDirectionalLights detected - please delete all but one

    Even though there is but one DDL in the scene. When transforming the DDL, the framerate slows to a crawl--this also includes adjusting it through a matinee sequence. This error sticks and practically ruins a map as deleting the visible DDL and re adding it shows the same error. So sticky is this error, that starting a new map and adding a new DDL from the actor classes browser still does not fix anything.

    The editor must be restarted, a new map must be made, and a non archetyped new DDL must be created. Then, everything works just fine, no error and no FPS slow down; I imagine it has something to do with clearing the clipboard.

    This is not some sort of critical issue as it can be easily worked around, but it has the potential to ruin a map if one does not catch it (i.e. error checking for the first time after weeks of development).

    I hate to bump this topic, but it happened again. This time, it showed up randomly in my map after a few days of development. It renders a map unsuitable for a game as the framerate suffers, severely so during a matinee sequence.

    Is there not some way to clear out any trace of a dominant directional light?


      Don't know if this will help you, but the clipboard can be pasted to a text file. You could examine it to see if there's anything obviously wrong, edit it and re-paste.


        Thanks for the reply. Well, this time it showed up randomly, and I know I was doing nothing clipboard related. In fact, I did not even touch the light itself unlike before.

        If I had to fathom a guess, it would be DX11 as it seems to be the root of every UDK bug I have ever encountered--I suppose I shall give that a test.