Announcement

Collapse
No announcement yet.

Slow Materials Editor pauses and is non-responsive for 5 to 6 minutes when editing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Slow Materials Editor pauses and is non-responsive for 5 to 6 minutes when editing

    Opening the material editor or editing a material inside of the material editor makes the whole program non-responsive and paused for 5 to 6 minutes per each edit. Making it hard to keep a workflow when editing materials. For me it seems to happen more when I’m exporting a material as a FBX from Maya 2013, but I think it’s happening when I open any material inside of the material editor. This pause even happens for non-complex materials when there’s only one or two nodes latched on to a material.

    My system is Windows 7 Home Premium, Service pact 1, Alienware X51, Inter Core i7-2600 CPU @ 3.4. 8GB Ram, 64-bit, 1.5GB GDDR5 NVIDIA® GeForce® GTX 660 graphics card.

    I’m having the problem with two latest updates UDK-2012-05-BETA and UDK-2012-07-BETA. The problem doesn’t exist on UDK-2012-02-BETA but I’m hoping to upgrade one day. Any help will be greatly appreciated.

    #2
    I have some slow-down too (some freeze like you, but not so long) on the July beta while it's fine on January beta.
    I guess it's the beta itself which is the problem and not your computer.

    Comment


      #3
      That's just it. It has to be something with my computer because my other old slow HP G71 Notebook PC which only has an Intel(R) Core(TM)2 Duo CPU T6600 @ 2.20GHz and a bad a graphics card doesn't have the same problem and doesn't pause for 6 minutes when editing the material editor. Only the fast Alienware has the stalling problem. I know it has to be something with my computer that's making it pause for this long.

      Comment


        #4
        Did you tried different drivers for your graphic card (Updating or Downgrading it) ?

        Comment


          #5
          Originally posted by Froyok View Post
          I have some slow-down too (some freeze like you, but not so long) on the July beta while it's fine on January beta.
          I guess it's the beta itself which is the problem and not your computer.
          I bump my old message because it's seriously annoying. Some friends have already agreed with me about this so I don't think we are here the only ones with this problem.


          The material editor since 2/3 beta is a pain in the a*s. As I said before, using the January beta works fine (well, the compilation time of the nodes is reasonable). I'm using the November 2012 beta since a few weeks and it slow down a lot my production because of the poor performances in the material editor.

          Draggin a new node ? Take 2 seconds.
          Deleting a node ? Take another 2 seconds.
          Connecting the inputs of a node ? Another 2 seconds, or even more.
          Changing the value of a node (like a constant) ? 2/5 seconds.
          And of course I'm talking about materials with a limited number of instructions, imagine it worse on complex shaders.

          And this is on one of my best computer, on my laptop it's worse. I can't work like that.
          I know that in the past there were some betas with some problems on this issue and it was most of the time fixed.
          Now, after a few beta since January, I really think it should be already fixed.


          I can't believe you guys at Epic can work in these conditions. It's certainly frustrating for you too. :\

          Comment


            #6
            You could turn off the realtime viewport (and any other realtime displaying) to get it to do everything pretty much instantly.
            That does mean you're unable to check the effects of what you did until you turn it back on.

            Comment


              #7
              Disabling the realtime refresh doesn't have any effect unfortunately, I still get very, very long loadings. I believe it's because the material editor do a refresh every time you create a node, even if you have disabled the auto-refresh (Fraps update its FPS counter when I add a node, during 1/2 seconds, meaning the viewport is updated).

              Comment


                #8
                Originally posted by Froyok View Post
                I believe it's because the material editor do a refresh every time you create a node, even if you have disabled the auto-refresh
                True, it makes a refresh. I guess you only had realtime viewport on.
                As I have all of them on, it makes a very noticeable difference when turning them off.

                It's odd though. I have maybe half the system you have (according to your sig) and for me it's not really slow.
                About 1, max 2-3 seconds if I run multiple programs (ie the game, 3DSMax etc) and when having the realtime displays on about 5 sec.

                Comment


                  #9
                  Well my pc is like some digitron when i look at your pc specs, but everything run fine, hmm try to reinstall udk completely

                  Comment


                    #10
                    Originally posted by Boshko Savich View Post
                    Well my pc is like some digitron when i look at your pc specs, but everything run fine, hmm try to reinstall udk completely
                    I don't see why reinstalling the UDK would help, even a fresh install give me this problem. And I tried on computers with drivers updated of course (both ATI and nVidia).
                    I have also only the UDK launched when I work to be sure my performance don't go down.

                    Comment


                      #11
                      Create a multiply node (don't connect anything to it) and plug it in to an empty slot. It will error out and material will look like the default material. However, it should speed things up considerably as it will stop updating the material with every action you make.

                      I do this for on complex materials as even turning the real time update off doesn't really speed things up, especially in dx11 mode.

                      If this doesn't work for you, then I can say with 100% certainty that there is something wrong with your system, or your UDK install.

                      Comment


                        #12
                        Originally posted by RNG View Post
                        Create a multiply node (don't connect anything to it) and plug it in to an empty slot. I will error out and material will look like the default material. However, it should speed things up considerably as it will stop updating the material with every action you make.
                        Excellent idea, I just tested it and it helps a lot since the editor doesn't compile the shader anymore ! Thanks !


                        However, it's just a workaround... :\

                        Comment


                          #13
                          I had exactly the same issue here really really annoying

                          Comment


                            #14
                            yep, I also have this problem.
                            For me, change the Constant3Vector is almost imposible!
                            There're slowdowns creating nodes too.

                            Comment

                            Working...
                            X