Announcement

Collapse
No announcement yet.

UDK Fatal Error during installation -- Running Windows 7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Fatal Error during installation -- Running Windows 7

    I cannot get July 2012 UDK Beta to install properly.
    At first it said I need XP Service Pack 3 but I read on another page (the link to which I have now lost) that you can bypass the UDK Install .exe searching for SP3 by making a shortcut and adding " -progressonly" to the end of the target.
    Now all I get is the logo followed by an error sound and the window has "UnSetup.exe -Fatal error" as the title in task manager.
    Have tried redownloading and trying older builds available on the UDK dl page.
    My PC should be up to specs...

    Windows 7 64x
    4 GB RAM
    Intel Core i7 CPU 870 @2.93 GHz
    NVIDIA GForce GTS 450

    #2
    Just Click the udk installer not use custom commands udk does work on win 7

    Comment


      #3
      Originally posted by Zeqzy View Post
      Just Click the udk installer not use custom commands udk does work on win 7
      Really? I mean it has "Windows 7 64-bit" under the Recommended for Content Development: heading in PC Specs on the downloads page...?
      The " -progressonly" thing was something I found in an old epicgames/udk forum thread when trying to google my problem.

      Comment


        #4
        Still haven't had any luck with this. I have friends who ran UDK on Win7 with no issues, not sure if theirs was 32 or 64 bit.

        Comment


          #5
          i use win7 64 bit on various machines without any problems, try installing it to a different partition eg not C:

          also make sure you have admin rights on your machine

          Comment


            #6
            Originally posted by geodav View Post
            i use win7 64 bit on various machines without any problems, try installing it to a different partition eg not C:

            also make sure you have admin rights on your machine
            Yes I have admin rights and have tried Run as Administrator
            When I run the installer I don't get a screen asking me where to install. The logo screen (http://i.imgur.com/xKRU7.jpg) pops up and after a second or two I get an error sound, then the window freezes until I close it by right clicking on the start bar or through Task Manager. The window title in the Task Manager shows UnSetup.exe - Fatal error.

            Comment


              #7
              Which antivirus program you have? If your OS is up to date, then try to disable antivirus - find Run at start up or something similar, restart OS and try again.

              Comment


                #8
                you might also need framework .NET 4.0 , think thats what its called, its part of windows 7 so it doesn't cost any thing

                Comment


                  #9
                  Originally posted by VendorX View Post
                  Which antivirus program you have? If your OS is up to date, then try to disable antivirus - find Run at start up or something similar, restart OS and try again.
                  Tried turning off my anti virus, trying installer again; didn't work. Then turning off run at startup on my antivirus, restarting, running installer again. Still nothing.

                  Originally posted by geodav View Post
                  you might also need framework .NET 4.0 , think thats what its called, its part of windows 7 so it doesn't cost any thing
                  I already have . NET framework 4.

                  Comment


                    #10
                    Originally posted by geodav View Post
                    you might also need framework .NET 4.0 , think thats what its called, its part of windows 7 so it doesn't cost any thing
                    He is right, man!

                    The same problem was happening to me "you need at least windows XP with service pack 3 installed". I also have windows 7 on my machine, and tryed several times install UDK, without success, with the same message at the end. The solution?

                    I downloaded the version from july of 2012, then a window automatically appeared on my screen, asking if I want to install microsoft framework NET 4.0 (when it appears click yes). After the installation, my computer restarted, and the program UDK begun to install.

                    Thus, this process just took about 15 minutes, so do it! And if your UDK does not make appear this window automatically before ( the window to install framework NET 4.0), try to download it manually.

                    I hope I have helped

                    Comment


                      #11
                      Ehm, you've jsut necrobumped a thread which was dead since a year. :P

                      Comment


                        #12
                        sorry, but the same problem was happening to me, and discovered the solution, I tryed to share, but didn't know it was dead. Now if someone has the some problem, he could know what to do

                        thanks!

                        Comment


                          #13
                          "you need at least windows XP with service pack 3 installed"

                          Originally posted by felipeANDRES View Post
                          sorry, but the same problem was happening to me, and discovered the solution, I tryed to share, but didn't know it was dead. Now if someone has the some problem, he could know what to do

                          thanks!
                          The problem is still happenning. The July 2012 and Feb 2013 builds work fine for me, but as soon as I start the July 2013 installer I get the "you need at least windows XP with service pack 3 installed" error. Since I just uninstalled/reinstalled the previously mentioned UDK versions, it cannot be that my OS has changed. Must be a UDK installer problem...

                          Comment

                          Working...
                          X