Announcement

Collapse
No announcement yet.

lightmass not baking transparent materials shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    lightmass not baking transparent materials shadows

    i think there is an issue with the baking of the masked materis in the last UDK release, for some reason the materials with alpha doesnt cast baked shadows anymore but only dynamic ones, i tried looking in the lightmass parameters but i found nothing...
    there isnt any strange parameter in the shader, just a diffuse and its alpha plugged in the opacity mask of the shader.. here is a screen, notice the foliage is not casting any shadow but the trunk does, oh and the baking ON it works so i really dont know what is wrong, if im doing something the wrong way, or if this new release is broken.. http://imageshack.us/photo/my-images/840/screenyyl.jpg

    #2
    It's a bug in the May version. Same thing happens to me and as far as I know, there's no way to fix it and we'll have to just use an older version of UDK or wait for the June Beta and hope it's fixed.

    Comment


      #3
      thats quite a fail, it better be fixed, i guess i'm not the only one using masked materials...

      Comment


        #4
        I can confirm that this happens for me as well; static shadows are not cast by masked materials.

        Comment


          #5
          Same here

          Comment


            #6
            i tried loading the game on an iPad2 and the masked materials are not even showing anymore.. i tried rolling back to a previous version of the UDK and its all working perfectly, what are all those problems with masked materials that came in this udk release? they are kinda broken at the moment.. no one found a solution for this? its a pretty bad problem and i really hope to solve it soon... its completly stopping my project at the moment..

            Comment


              #7
              I've found a workaround:

              in the material properties of your masked materials:
              - set the masked material to Blend_Translucent,
              - Connect the alpha texture to opacity
              - Enable: 'Cast Shadow as masked' under 'Lightmass Settings' ( still in material properties)

              Run Lightmass and switch your materials back to Blend_Masked afterwards

              Comment


                #8
                oooh that works! Thank you

                Comment


                  #9
                  yes that works, but the problem is that if i have many materials in the scene that uses a mask, the iteration between the 2 shader type is not really fast and switching to translucent, build light and to switch back to masked can take some time (excluding light build ofc) considering the shader recompile time... hopefully it will be fixed in the next udk release...

                  Comment


                    #10
                    Thanks guys! And thanks for discovering a workaround. Just wanted to let you know that this is already fixed for the next release.

                    Comment


                      #11
                      Awesome, thanks for the info

                      Comment


                        #12
                        Awesome, Thanks! I'm guessing at a July release?

                        Comment

                        Working...
                        X