No announcement yet.

[Solved][UDK May 2012 Problem] Skeleton Mesh ROLL Rotation different from AnimSet?

  • Filter
  • Time
  • Show
Clear All
new posts

    [Solved][UDK May 2012 Problem] Skeleton Mesh ROLL Rotation different from AnimSet?

    Hello UDK staff,

    I originally posted my issue in the animation forum (see link below) but realize my problem is specific to the UDK May 2012 build.

    I am now forced to use UDK March 2012 beta which is unfortunate since I was looking forward to the new iOS scaleform feature in the May 2012 build.

    Original Post:

    Here is the Full Post:
    Hello Everyone,
    I am having an issue and seek your advice.

    Description of Problem:
    UDK March 2012 - Successfully imported a skeletal model (.fbx) in the past UDK build (March 2012), put it into an Animtree and synced with UScript (It was working fine).
    UDK May 2012 - After a re-import into May 2012, the same model (.fbx) (which hasn't been touched since importing into March 2012) is having rotation problems. When I attach it's Animset to the Skeletal mesh (via animset editor), the "ROLL" is off by -90 degrees (Character lays flat on his face). Weird thing is, I have the old mesh saved in a package (saved in the UDK directory from March 2012) and it works fine in May 2012.
    The problem is that I have other characters importing with the same incorrect results and I'm trying to figure out why they all rotate when I attach their Animsets to them (Different characters and different AnimSets).

    1. Import Skeletal Mesh (Imports with its AnimSet).
    2. Open the skeletal mesh ( AnimSet Editor ).
    3. At this point mesh rotation is correct (Animset is none in drop down. No Animset picked yet.).
    4. Pick the correct Animset from the AnimSet tab's drop down menu ( this is the correct AnimSet).
    5. At this point, the mesh "Roll" rotation is off by -90 degrees.

    To correct this, I add +90 to the ROLL rotation which you'd think would be ok but it is not, whey I preview this in my AnimTree, the model lays flat on his face when its not in Phys_Walking!

    Other Tests (all fail):
    A. Imported an older model that was working perfectly in August 2011, November 2011 and it is having the same issue.
    B. I removed all my content and re-imported the model.
    C. I rebuilt my scripts.
    D. ReInstalled UDK May 2012.

    9:30 PM CST Update:
    I just reimported the skeletal mesh and animset into March 2012. The problem has disappeared!

    Please enlighten me with your thoughts, I will be most appreciative.
    My theory is that this is a UDK bug!

    Okay so the UDK Importer does not report this in the UI but I found the error in the UDK log file. I wonder why it wouldn't stop the import! Notice it says warning, shouldn't it be an Error?

    []Log:Warning: A bone or bones with a non-identity scale factor was found for skeleton (skeleton root name: NRPMan_j_Root).
    Unreal does not support scale on bones so the FBX importer will attempt to apply the scale to the bone's translation. If the results are not as intended, please use identity scale for all skeletons in the original scene.


      Here is the latest,
      UDK May 2012 - Fix
      1. We fixed the Scale issue, the identity-scale warning no longer displays in the logs.

      UDK May 2012 -Problem
      1. Upon import, the skeletal mesh does not save to the AnimSet.
      2. When the imported animset is selected in the AnimSet Editor, the mesh rotates and the model lays on his back.

      UDK January 2012 - The Skeletal Mesh and AnimSet import and work properly (Mesh is translated properly in AnimSet editor).

      Has anyone noticed any rig,skinning or animation adjustments for UDK May 2012? (I'm interested in hearing changes for which ever modeling program you use, we are using Maya 2012)


        i get no import problems but use 3ds max 2011.
        could be a maya problem?


          This is obviously an issue in the Present UDK May 2012 build and past UDK builds.

          Production is been stopped. I'd hate to proceed with an unknown issue lurking in our skeletal meshes.

          Does anyone have a remedy? I will be most appreciative if you could share your experiences.


            How to solve this this issue for Maya 2012 and UDK May 2012 (FBX Version):
            [This is not in any particular order, just guildines]
            -Make sure to follow all the guides for making a custom character.
            -Clear History (In both UDK and Maya)
            -Before you detail your mesh and animations, create a test Skeleton with 1 animation, make sure this imports properly into UDK.
            -Check your logs when importing, look for any warnings and errors.
            -Root Bone at 0,0,0 in Maya.
            -Do not scale bones in Maya.
            -Export from Maya with Z-Up Axis (Bake animation 30 FPS, Smoothing Groups exported and all recommended FBX export options)
            -Import into UDK with (Use T0As Ref Pose = True, Preserve Smoothing Groups = True, Import Meshes in Bone Heirarchy = True)

            Today was a good day as I believe we've beat this into submission.

            My words of advice while in the middle of production.... if you really neeed one of the newest features in UDK's latest release, please be prepared to make changes to your existing models. It may be easier to lock your UDK version and not upgrade.

            Have a good one and good luck.


              Deleting history on a mesh in Maya after you've rigged it is NOT a good idea. Delete history on a mesh right before skinning it to the skeleton or else you'll run into tons of problems.


                We are investigating this issue and I will post back when it has a resolution. Thanks for posting!