No announcement yet.

FullScreenMovie Does not work, At all. (iOS)

  • Filter
  • Time
  • Show
Clear All
new posts

    FullScreenMovie Does not work, At all. (iOS)

    Would just like to report that FullScreenMovie, along with all the .ini commands do nothing, as in.

    We have put our movie as the Loading Movie and even with the should stop playing on load bool, just plays the video audio in the background after it's loaded but draws the game on top.

    Adding our custom named movie as a Skippablemovie, does nothing.

    The command MOVIETEST does not work..

    Hopefully we can get some more insider info on this,


    Does it work on PC? Just to rule out that it's not an issue with your setup in general and indeed related to iOS.

    There are also some known issues with Bink movies playing only sound with black screen at times when you are not running the game in fullscreen mode (and possibly also when not in native resolution in fullscren).


      We know our movie is fine as if we overwrite the loading movie with it, it plays up until it's loaded and then the game draws over the video but the sound keeps playing from the vid. ( Even though the stop on loaded bool was set to false)

      Also tried it on a PC game and the command doesn't work, nor does it try and autocomplete it.


        What movie are we talking about exactly?
        StartupMovies or LoadingMovies? Because I thought SkippableMovies only applies to the StartupMovies while LoadingMovies will always play as long as the map is being loaded and are skippable after that (and required to be skipped if StopPlayingAfterLoad is False).

        Also, StartupMovies has a little behavior twist in it (as I found out with the help of a dev when I encountered problems with it recently as well):
        The last movie in the StartupMovies array is ONLY played (and looped) if your opening map didn't finish loading by the time it reaches that movie, which is probably never the case for a simple frontend menu map.

        So my entry in the DefaultEngine.ini had to actually look like this:
        "enter" is our loading screen movie. As StartupMovies do I actually only want to play "UE3_logo" (inherited from the BaseEngine.ini), "Licences" and "Intro" but not the actual "enter" movie. That one is only there as a fail-safe in case the map didn't load yet by the time the other movies all played.

        Also, with test on PC did I mean using the "-fullscreen -resx 1680 -resy 1050" parameters on your UDK shortcut (with resx and resy being your native resolution), put your movie in the list as in my example there and then see if it actually plays fine with that.

        The description for the MovieTest command also says that the the game waits for it to finish and then should stop it, so you can't skip it either, I guess.


          If i run UDK with that it just runs UTDeathmatch.. i need to set mine as default somehow..

          Ok my default game in DefaultGame is the right one...


            We incorporated the license video into our movie..

            This still doesn't work, nothing plays.

            (TESTED ON iPAD3)


              Try adding the StartupMovie and SkippableMovie twice? Just to be sure? And does it work on PC then?
              Otherwise I am left clueless as well. :/

              Also, you can modify your shortcut in this way to have several shortcuts for quick testing of maps and gametypes:
              UDK.exe MyMap.udk?game=MyPackage.MyGame


                When you say, Mypackage.Mygame.. i don't know what to put, my game is an iOS game and it isnt stored in a package...


                  Also the video does not play on the device.

                  I could do it in Scaleform but i need to be a licensee of UE3 and Scaleform.


                    MyPackage.MyGame refers to the Development\Src\YourPackage\YourGameInfoSubclass.u c that is used as GameInfo class to start the map with.


                      My FFGameInfo is in SRC/Warlock/Classes so i put this.

                      C:\UDK\UDKFEB\Binaries\Win32\UDK.exe Exterior_p.udk?game=Warlock.Classes.FFGameInfo.uc

                      also tried

                      C:\UDK\UDKFEB\Binaries\Win32\UDK.exe Exterior_p.udk?game=Warlock.Classes.FFGameInfo
                      C:\UDK\UDKFEB\Binaries\Win32\UDK.exe Exterior_p.udk?game=Warlock.FFGameInfo
                      C:\UDK\UDKFEB\Binaries\Win32\UDK.exe Exterior_p.udk?game=Warlock.FFGameInfo.uc


                        C:\UDK\UDKFEB\Binaries\Win32\UDK.exe Exterior_p.udk?game=Warlock.FFGameInfo

                        this would be it then.


                          That just plays it as PC Mode UTGame. As the touch to move system from our game isnt in nor does our movie play.