No announcement yet.

Network/Internet trouble

  • Filter
  • Time
  • Show
Clear All
new posts

    Network/Internet trouble

    UDK is crashing my internet, let me explain.

    recently I had to move and now I have no way to set up a wired connection to the router broadcasting the internet signal, I am stuck with wireless adapters. I had trouble with some adapters, which i why I at first thought this, again was an adapter issue, but i found one that works absolutely fine with my machine now. Now I go to work with the UDK and all of a sudden my internet connection drops. First the connection "bars" go down and then the packets stop flowing (I finally started doing tests with the "Wireless Network Connection" window open on the side to see what was going on), and then I see "IPv4 connectcivity:" drop to "No Internet access". I close down UDK and everything springs back to normal. So, that i why I now think it really is a UDK problem. I have not had ANY issues for over 2 weeks with this wireless adapter while I was working in Maya and ZBrush and surfing Netflix and Youtube at the same time and no interruptions or anything. I go to bring my work into UDK and the problems begin.

    I tried re-installing the drivers for the adapter, getting the lastes drivers from ASUS, trying different adapters, turning off my firewall... I installed the Feb 2012 beta, perhaps i should try the latest March one?? (I had an old beta from July 2011 earlier this week when i first noticed the problem) But if there is NO report of any kind of problem like this then I suppose this issue has not been addressed in any of the versions yet (I tried searching any kind of phrase with UDK and network or connection problems and found zero). I am at my wits end and have absolutely ZERO idea why this program would cause any kind of glitch with my network.

    Please, any ideas would help. I am considering trying to get a PCIe wireless card (maybe its a USB issue?? UDK interrupting USB ports? but again I cannot find anyone posting anything like that anywhere) or getting a Wireless Range Extender and using that to hard wire to the internet. Actually I will probably lug my machine downstairs tomorrow and try hard wiring into the router and test to see if I get any internet interruptions.
    Does anyone else run UDK on a wireless internet system? I need help! Please!

    How many times have you tested this? I have a laptop that I occasionally use with UDK and have never had those kinds of issues... I know UDK is a moderately "heavy" app, but I can't imagine it drawing so much power from your laptop that it can't afford to give full power to your usb ports... Do you have any other usb ports you can use as an alternative? If you're using a usb hub by any chance, try removing it and plugging your wireless card directly into the machine and see if that helps as well. If you're not plugged in to the wall whenever you open UDK I'd try that as well. If by strange circumstance it IS somehow affecting your wireless card directly (doubtful, but in these kinds of frustrating circumstances it's worth trying) you could try disallowing UDK any access to your network via settings in your firewall or Windows 7 if you're using it.


      Never had that issue with my laptop on wifi and using UDK on it. Try blocking UDK on Windows firewall. Make sure to block the correct UDK process. If that doesn't fixes it, it probably is not UDK related.


        Thanks for replying. I'm sorry I did not post the following above... kinda felt like I was rambling up there so I tried to keep it short, I have a habit of rambling... I'm not using a laptop, this is a desktop, Gigabyte P55 UD3R mobo with Intel i5 (2.6Ghz), 8GB of G.Skill RAM (UDK is not getting anywhere near maxing out my system when i run it, at least not standard building operations, recompiling is different, but this network issue pops up almost right after i start the program).

        This was a whole days of testing, over and over again, whenever I made one of the changes I mentioned; new drivers, different network adapter, new version of the program etc. I have tried blocking UDK with my firewall, that was the first thought I had but it doesn't seem to work (I'm using AVG Internet Security), but perhaps I'm not doing it right, tho I cant think what other UDK linked applications I would need to flag. I flagged the UDKLift, and the two UDK.exe 32 and 64bit.. what other ones would need blocking??

        I'm not using a USB Hub but I'll try moving the adapter around to different ports, I have not tried that yet, tho I do not seem to have any problem with my USB keyboard or mouse or tablet when UDK is running... I'll test that next, and try getting my PC close enough to the router so I can plug in a cable and test the network that way. Also, as far as stress, I have stressed the machine well, running Maya, Photoshop, ZBrush and Firefox at the same time, slowing everything to a crawl basically but i still have fine internet access. Its driving me nuts that I finally have the network running fine after almost 2 months of trying to find a wireless adapter that works only to find it totally shut down in ONLY ONE program.

        Again, thanks for the reply. If anyone has any idea why this may be happening or what UDK is doing in the background (any kind of process that is accessing a server to check for content or versions??) I noticed this UDK version installed Microsoft .Net Framework but like i said before i was having this problem in the 07 211 version as well. I'd love ANY help.


          OK! I tried different USB ports, I tried blocking every application I could think of in my Firewall and Windows firewall... Then i checked the properties of the adapter in device manager, everything seemed fine, but under the Power Management tab I saw that "allow the computer to turn off this device to save power" was checked. I had played with turning this function off when I was trying different adapters (as the problem i had was that the adapters were dropping connection every couple hours and needed to be taken out and re-inserted to work again, sometimes) but that had never helped. For some reason I had forgot about this automatically checked box, probably because i did not have any problems like that with this adapter and when this started happening with the UDK i did not try un-checking it.

          Thankfully this has solved my problem (hours and hours of running the program no and no internet hijinks). I am still confused as to why UDK would cause a reaction like this with the adapter. Thanks for the replies.

          Cheers all