Announcement

Collapse
No announcement yet.

[SOLVED]The lighting build failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED]The lighting build failed

    When I try to build all i get this message:


    I have tried everything suggested in the other threads and none of them worked. I am using the December 2011 UDK Beta.

    Swarm log:
    Code:
    21:52:08: [Interface:TryOpenConnection] Local connection established
    21:52:08: [Job] Accepted Job 052D47AE-432FBF01-28DC46BF-D76D15BC
    21:52:08: [Job] Launched Job UnrealLightmass_2011-12-21_18-10-21_981784-64bit.exe
    21:52:08: [Job]     PID is 5900
    21:52:08: [Job]     GUID is "052D47AE-432FBF01-28DC46BF-D76D15BC"
    21:52:08: [Job] Job has failed! Job executable didn't exit cleanly. Exit code: 1
    21:52:08: Log file created: UnrealLightmass_ALEX_275E4847483DE537A1F007B6B09DAC64.log
    21:52:08: DirectX run-time isn't installed or it's using the incorrect version!
    21:52:08: Lightmass requires D3D_SDK_VERSION 32 and D3DX_SDK_VERSION 43.
    21:52:19: [CloseConnection] Closing connection 4FC86FD7 using handle 4FC86FD7
    21:52:19: [CloseConnection] Connection confirmed for disconnection 4FC86FD7
    21:52:19: [CloseConnection] Closing orphaned Job (052D47AE-432FBF01-28DC46BF-D76D15BC)
    21:52:19: [CloseConnection] Connection disconnected 4FC86FD7
    21:52:19: [GetMessage] Safely returning to 4FC86FD7 with no message
    21:52:20: [MaintainConnections] Local connection has closed (4FC86FD7)
    21:52:20: [MaintainConnections] Removed connection 4FC86FD7
    21:52:20: [MaintainConnections] All connections have closed

    #2
    21:52:08: DirectX run-time isn't installed or it's using the incorrect version!
    21:52:08: Lightmass requires D3D_SDK_VERSION 32 and D3DX_SDK_VERSION 43.
    That should clue you in on the issue.

    Seems like you skipped it when installing the prerequisites when installing UDK perhaps.

    Comment


      #3
      Originally posted by Graylord View Post
      That should clue you in on the issue.

      Seems like you skipped it when installing the prerequisites when installing UDK perhaps.
      But I have DirectX run-time installed Could it be because im using the 32-bit version of UDK.exe and not the 64-bit version? When i run the 64-bit version i get this error:

      Comment


        #4
        or it's using the incorrect version!
        Have you checked which version you have?

        Comment


          #5
          Originally posted by Graylord View Post
          Have you checked which version you have?
          DirectX 11

          Comment


            #6
            Er, you'll need to be way more specific. Direct X 11 has many updates.

            Also, if your editor is set to DX9, you'll also need to update that. The DirectX's work independently on eachother, updating one doesn't update the other.

            Think of it as a game franchise, just because it's the last game in the series, doesn't mean it's updated.

            Comment


              #7
              Originally posted by Graylord View Post
              Er, you'll need to be way more specific. Direct X 11 has many updates.

              Also, if your editor is set to DX9, you'll also need to update that. The DirectX's work independently on eachother, updating one doesn't update the other.

              Think of it as a game franchise, just because it's the last game in the series, doesn't mean it's updated.
              I've finally fixed it and the 64Bit version works I downloaded a program called "Dependency Walker" and i found there was a problem with D3DX9_43.dll, so I deleted it from system32 and reinstalled directX and it now works. Thanks for the help.

              Comment

              Working...
              X