Announcement

Collapse
No announcement yet.

Mouse Freezing Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mouse Freezing Issues

    Hello, I've been having a major issue. When using UDK editor, I get these random mouse lock ups. Basically, i'll be doing something, manipulating geometry, moving brushes, usually basic stuff, and then the mouse cursor seizes to move. Not just in the editor, but when I attempt to do anything else on my pc. I thought my pc was frozen, but I can still do stuff with the keyboard. The mouse cursor just refuses to move. In an earlier release this would happen, but it would unfreeze when I spam clicks. Now in the October release, the only thing that releases it is closing the editor. Oddly enough, if im closing the editor, hit 'save selected' and then if a dialogue box pops up thereafter, then my cursor is released. The problem mainly occurs when in geometry mode and resizing brushes. It's terribly frustrating and hinders my progress. Any help would be greatly appreciated...

    #2
    Originally posted by Keevee View Post
    Hello, I've been having a major issue. When using UDK editor, I get these random mouse lock ups. Basically, i'll be doing something, manipulating geometry, moving brushes, usually basic stuff, and then the mouse cursor seizes to move. Not just in the editor, but when I attempt to do anything else on my pc. I thought my pc was frozen, but I can still do stuff with the keyboard. The mouse cursor just refuses to move. In an earlier release this would happen, but it would unfreeze when I spam clicks. Now in the October release, the only thing that releases it is closing the editor. Oddly enough, if im closing the editor, hit 'save selected' and then if a dialogue box pops up thereafter, then my cursor is released. The problem mainly occurs when in geometry mode and resizing brushes. It's terribly frustrating and hinders my progress. Any help would be greatly appreciated...
    YES, I'm having the same WORK STOPPAGE issue; which is seriously impacting my bottom line. (Self employed, indy developer trying to ship a product within a few weeks) PLEASE FIX THIS.

    Win 7 x64, Explorer mouse and Kensington mouse have same issues. Standard Win7 drivers and updated mouse drivers. Same issues persist. - Mouse can click and move within the window it became"trapped" in and no other apps will respond to the mouse. Kill UDK from task manager and restart.

    -BECAUSE CTRL+S doe NOT save - ANY WORK IS LOST.

    Part 2 would be a request to remove Ctrl+S and make it actually SAVE. If this is possible through configuration, please direct me to the documentation.

    Comment


      #3
      I'm using the November build and this happens every so often during the same circumstance as Keevee; during the Brush edit mode (Shift - 2).

      The only thing I've been able to do to get it to unfreeze is to cycle through the different modes, Shift -1, Shift - 2, Shift - 3, etc.. But, it is still rather annoying because sometimes it's quicker to just restart the editor, especially if I've just saved.

      Comment


        #4
        I have the same problem, but i use alt f4 to close so that I can save on exit, anyone have a solution?

        Comment


          #5
          Originally posted by fragfest2012 View Post
          I have the same problem, but i use alt f4 to close so that I can save on exit, anyone have a solution?
          Is this solely in brush edit mode or does it happen throughout the editor, or does it happen generally on your PC?

          Comment


            #6
            It can happen for moving anything, it has happened so far recently moving lights, bsp, and fractured meshes. It never happens to me otherwise and I have a good mouse with recent drivers as well as a nice computer. I am running win 7 64 bit, by the way.

            Comment


              #7
              Still don't have a fix...

              Comment


                #8
                Just a noob suggestion, are you sure its not the autosave feature? I have no locked mouse, but for me UDK does not respond when its busy autosaving. Which can be annoying when working with large levels / packages.

                Comment


                  #9
                  Okay, so i got a mouse locking issue as well but it happens only on the feb 2012 build.

                  Whenever i use the play in viewport button (alt+f8) while having the udk editor window maximized and then i press the esc key (to exit the play mode) my cursor is freezing at the very top of the screen and it is locked but only in the Y axis (means i can still move the mouse but only left or right) and it unlocks when i close udk or if i press alt+tab.

                  It does not appear to do that if i have the udk window shrink down a little bit though :/ what the hell is happening? frigging weird..

                  My res is 1920x1080 and the locking is not happening in jan 2012 release or older.

                  Comment


                    #10
                    Perhaps it's just bad hardware/software/driver combination?

                    Hi guys, I've only recently got this problem too, I'm using September 2011 version. Thing is it never used to happen (I've been using it since September), I reformatted and got myself an SSD very recently, installed all the latest drivers, used several mice, and that's when it started happening. Perhaps it's just really bad luck/design and there are certain drivers/hardwares UDK doesn't like?

                    Windows 7 64 bit on a solid state drive was the only difference. I just grabbed my udk folder and shoved it onto my SSD and things were dandy but this little annoying bug just keeps persisting every half hour. :/ It seems to be a pretty common problem, for me it is very recent, and I've never encountered it until now. I've been using udk for the past two years?

                    Comment


                      #11
                      i had similar problem after exiting play-in-window.
                      my solution was to use windowed mode and have a gap between the top of the desktop and the top of udk.

                      feb 2012 version 9505 desktop size 1280x1024

                      Comment


                        #12
                        (late reply my bad) but I am not sure if autosaving might be causing it. I am pretty sure not, because I can open UDK, and it can happen seconds later, or hours later. It's frustrating. Every build has it happen. Graveljaw, what you explained is my exact same issue. Also, TK-Master, I have had that same issue. Sounds like an odd problem... is there anyway to get a hold of Epic and see what the programmers can say?

                        Comment


                          #13
                          Also having the same issue after pressing play then exiting with Esc key... but only mouse Y axis is locked. Switching to another window by clicking, or Alt-Tab frees the mouse again.
                          Windows 7 x64, OS on SSD and UDK on a short-stroked HDD partition.
                          Happens with default windows drivers and with Mouse's provided drivers. ONLY happens in UDK editor.

                          Comment


                            #14
                            Hate to be this guy.. but .

                            HEY EPIC!!! HI!.. Over here!! (waves hands) We have a serious problem..

                            Has anybody looked into this issue? Is there a forum post that has worked this out?

                            This behavior has happened to me 3 times this morning so far (less than 2 working hours). Completely locking me out of getting work done..

                            Its constantly happening, and completely inconsistent when it happens.. It happens in Matinee.. It happens while editing brushes.. it happens while working in the Browser. It happens just moving around in the 3d scene.. BAM, your mouse is locked! Alt-Tab? NOPE.. Still locked..

                            I've gone thru every post i could find regarding this issue, and its clear a lot of people have it. Someone mentioned Autosave potentially causing this, and while i've tested with it off and on.. the only consistent solution i've found to un-locking the mouse is to get to the file menu (hopefully you can, with a combo of Alt, and Alt-Tabbing) and save your file.. once the file saves, the mouse becomes unlocked.

                            sidenote: this lock is full on locking the cursor. it locks the wacom tablet input as well. It remains locked until you can close UDK, save your file, or magically spaz out on the mouse and magically have it unlock. Very frustrating, and a lot of lost time due to this issue.

                            Comment


                              #15
                              3 times today - did notice something (maybe a coincidence - maybe not!). Everytime it froze was when I received a popup message from my virus update (it updates every 2 hours and pops up a system tray message to that affect). Also on Win 7 x64 (another coincidence with the above posters???). I save very often anyway, so didn't lose much.

                              Comment

                              Working...
                              X