Announcement

Collapse
No announcement yet.

Kismet Node Copy Crashes UDK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Kismet Node Copy Crashes UDK

    Hi.
    I have a problem that when I copy big chunks of kismet nodes, and paste them in UDK, sometimes it crashes. I even verify that everything is correctly copied by pasting it before in notepad, and everything appears to be ok, but most of the time, it crashes UDK. Some times even with little ammount of nodes.

    THnx.

    #2
    Why do you need to copy nodes like this? I usually use Ctrl+W to copy nodes within the same level.

    Comment


      #3
      I've been getting this same problem. One or two nodes will crash. It started in the Oct. Release. Nov just got worse it seems. All in all since the Sept. Release Kismet and kismet scripting has almost become unbearable.

      edit: I think I have found one particular node that seems to do it the most often: Remote Event. Not the action node, but the event node. Whether it has a matching pair or not doesn't seem to matter... doesn't crash right away, usually will sit and crank on it for a while then I have to manually exit. I will see if I can find others.

      Comment


        #4
        This is most definitely a bug and it perpetuated into the December. Its really sad actually, I was really hoping this would be fixed, as we're on three versions now where something as basic as copying kismet nodes crashes UDK. To Test: Open a fresh level, Create a remote event pair, name them both TestEvent. Now just try to ctrl-w the node. Crash. Even easier, Just create event/remote event. No pair needed. Try to ctrl-w. Try ctrl-c and then ctrl-v, either way its a Crash. Is this just my computer or what? Nobody seems to answer this thread so I can only imagine. I don't get any problems in the September release. Copy paste all day long with no crash. Sadly this means I will have to stay in a version where I can copy nodes with no problems. I'm really hoping this gets addressed soon, I really wanted to use the December version. I can't imagine this being a 'feature' in any possible scenario unless they're trying to neuter kismet. I hope not.

        Comment


          #5
          Hi indefiance,

          I tried this on the basic starter level and had no crashes with multiple copying, ctrl-c and ctrl-v, and ctrl-w. Of course, this was a small level with only the remote event pairs being copied. I'll test some more on something larger to see if I can duplicate that crash.

          Edit:

          Okay, I tried this with the Necropolis level - still no crashes or unusual behavior. One thought. Are you running UDK on a 32 or 64 bit OS? (Mine is Win 7 64)

          Comment


            #6
            Hey TMichael,

            Thanks for trying this out. After posting that I went on testing various scenarios trying to get to the bottom of it not realizing what a rabbit hole it would turn out to be. I realized that I was testing only what I thought was a 'fresh' level. I had forgotten, albeit innocently thinking it would make no difference since my code is rather limited and I didn't think it would cause this type of bug, in short I was updating each version of the UDK with content and code before opening the 'fresh' level for testing. I realized that this may be causing the issue and proceeded to actually test a real fresh level with a fresh install with no tampering. You have probably already guessed, the bug went away.

            So I spent the rest of the day yesterday trying to track down the problem. I started with my code, and installed it step by step by painstaking step. Testing for the bug as I went. Anyway, to get to the point: I found out it wasn't in my code at all. It was actually caused by a config file...defaultengine.ini loading a specific package at startup. This greatly confused me. I got rid of the startup load, and by manually testing the package, I find that the bug 'magically' appears only after loading a certain package. So I cleaned that package up of old stuff. Now I can load that specific package and not get the bug. So I thought I fixed it. I loaded up my levels, and found that the bug re-appeared. Then I realized it was probably more than just that one package. So, I'm racking my brain what could cause this and goto cleaning out all the old junk in all my packages I wasn't using. Then consolidating assets etc. (still working on that). Long story short, I still have no idea how a package could cause instability in every version past september, but that is what is going on.

            So, it still could be a bug, I just couldn't tell you what exactly is causing it. I though it might have been a memory problem too, so I loaded the entire package base from the defaults packages all at once, and loaded a level too, no bug. So I know its my specific packages causing it, but not what it is inside them. I tried using the commandlet 'fixupredirects' but it actually crashes when it tries to process through the suspected problem packages... I used the 'check package for errors' as well, and it doesn't find any problems. Conclusion: I have set about pretty much rebuilding and cleaning my entire package base, for a rather large project. I expect it to take me a couple weeks. I'm hoping it will solve the problem. I am more of a level designer than programmer, so I am at a loss as to what could cause this besides having a somewhat sloppy package base. My fault I suppose, and even if it doesn't solve the problem My project needed some housecleaning anyway.

            Again, thanks for testing that out for me. Maybe there is a bug somewhere, since I have no problems in September. If so, maybe this new info will help the dev's.

            Indefiance

            Comment


              #7
              Because this has been so extremely harmful toward my productivity, I thought I'd share a little of what I've found wrt this issue.

              Initially, it did/does seem like it had something to do with remote events. However, I just ran into an incident where it crashed EVERY time upon loading a fresh map and attempting a fairly basic copy/paste from one level to the persistent level. I even tried copying single nodes and they too would CRASH. Also tried "breaking all links" before copy/paste and it still CRASHED, even pasting within the same level. (We're going on about 12 consecutive crashes at this point)

              Here's what worked: I added a random node (it was a "toggle") then deleted it. Then I was able copy paste portions of the kismet into the persistent with no crashes. I'm guessing that I might have been able to copy the entire section, but I'm not about to go back and try it

              Hope this helps someone...

              Comment


                #8
                I've been getting this a lot too in recent versions, just copying kismet between sequences, even just a single action sometimes.. Haven't noticed any reproducible consistency though, just chiming in to say that it's ******* me off a lot too (win 7 64).

                Comment


                  #9
                  Thanks for bringing this issue back to our attention. We are looking into it. If you are able to reproduce the issue reliably, it would help us if you could post detailed steps in reproducing the crash.

                  Comment


                    #10
                    I can reproduce it on a clean march 2012 install.

                    1. Install UDK and run the editor
                    2. Make a new package. I called mine prefabs
                    3. Drag in a static mesh from the editor - I used the RemadePhysBarrel
                    4. Make a sequence in kismet and call it sub sequence (default)
                    5. Make a new take damage event using the static mesh in the level
                    6. test out the event by giving it 1 damage threshold and 0 max trigger count. Connect a log to it and log the instigator. Set the world properties to UTGame so you have a weapon.
                    6.5 Shoot the barrel - the event works and logs your controller as intended
                    7. Select the barrel and make a prefab out of it. Save it in the prefabs package and call it prefab1. Accept the kismet and replace the current actor with the prefab.
                    8. Alt-Drag out 3 more copies of the prefab. (Now 4 prefabs in the scene)
                    9. Select a prefab sequence in kismet and copy paste one of the log nodes. (I did ctrl+c ctrl+v, but ctrl+w works too)
                    If it doesn't crash, I get a blank node with like 8 connectors (I'm assuming all of the unexposed log connectors) that won't delete. (I press delete, it is still there but
                    immovable)

                    This image is of what happens when it doesn't crash ... I don't have a picture of it crashing right now but can certainly get one.

                    9a. Just copying and pasting several of these broken nodes probably isn't good, but I added a couple of new nodes into one prefab sequence and tried to copy paste: crashed.

                    I deal with a lot of prefabs at work - this bug is killing me. If I want to create a new prefab that does something just slightly different I have to make new kismet nodes one by one, which isn't so bad but making a new matinee from scratch really sucks.

                    Comment


                      #11
                      Hi,

                      I THINK I may have realised why it keeps crashing.

                      I have a similar problem to ilguano, but I just this second tried copying everything except the objects (interpactor_0, All Players, MyMesh1 etc. Forgive me if these things aren't collectively known as objects, kismet is a dark art to me) and it copies just fine. So basically I can copy all my actions and events as much as I like now, but the second I try to duplicate an object (perhaps because the object is in the level I have open?) I enter crashville.

                      Let me know if this helps!

                      Odog

                      Comment


                        #12
                        This is nothing new and has been a serious issue since at least December 2011. Reproducing it is trivial on my setup (win 7 64). Using Dec UDK.
                        Here are the steps:

                        1. Open a map
                        2. Copy some kismet/paste some kismet
                        3. Crash

                        There it is.

                        Now, if I do other things before copy/paste, I might be able to get away with some copy pasting before it crashes again. But NEVER can I copy/paste upon first opening a map.

                        There's nothing that could accurately capture the pure frustration and often rage, with UDK like this can. That's all I'll say about it.

                        Comment


                          #13
                          Graveljaw's find is interesting. When I attempt to copy paste without doing anything it always crashes regardless of the kismet I'm copying. Moving objects around arbitrarily for a minute allows me to copy paste though. This issue drastically reduces my ability to iterate on prefabs and levels in general.

                          Comment


                            #14
                            Any word if this issue is still being addressed?

                            Comment


                              #15
                              watslash, the prefab subsequence crash is a known bug. For now, I advise avoiding copy/paste of prefab sequences.

                              Anyone who has been seeing an increase in performance issues or crashes over time is advised to periodically wipe their UDK*.ini files in their UDKGame\Config folder, to see if that solves the problem (or at least back them up and remove them).

                              As for the original crash in this thread, if you guys can figure out what in your packages or scripts causes the issue, it would be greatly appreciated.

                              Best.

                              Comment

                              Working...
                              X