Announcement

Collapse
No announcement yet.

Shadow Bleeding! Help, if you would please!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadow Bleeding! Help, if you would please!

    Hello there, I am having some issues here with shadows and lightmapping. I’m not sure what is going on and it is very frustrating. With that said, I’m having issues with shadows bleeding through the wall. I’ll post up a series of photos maybe this will help you understand. I have tried to work on this for over 2 days now and no dice.

    I used 3DS Max to build my models, I do two different UV maps, channel 1 and 2. Channel 1 for textures and 2 for my lightmaps, I export them as FBX (I’ve tried ASE also, same results) and import that to UDK. My lightmaps are on channel 2 in 3Ds Max because I know UDK uses 1 for 2. My lighting in the map I am using so far is all Emissive lighting from the overhead lights which I setup I have no overlapping UVs, I know that for sure.

    I am using one point light between the two cabinets because my emissive light seems not to cast light on them if they are a mover. However even a spot light which I understand is a dynamic light is still creating my movers to have shadows through the walls. (This isn’t something I can just dismiss, this shadow error, I’m building an office building which will have rooms next to each other, an floors on top and bottom.)

    I do have a lightmass importance volume in the scene but its set at 256x256x256 and set outside of the scene because it makes everything too bright and looks horrible. I came across someone who said not to use CSG brushes for building rooms and to use static meshes instead and so I built the rooms completely in 3DS Max and setup precise collisions UV mapping and UV lightmapping and the movers still bled shadows through the walls. I have also tried setting up lights to use normal instead of modulated shadows, still didn’t work an tried setting the use similar mapping to false in the baseengine.ini file and finally in the world settings tried changing the ambient occlusion to true, and nothing.

    The only thing which seems to help is setting the model to indirect shadows or the wall to indirect, however in that case the shadow vanishes and it looks horrible. Here is some photos, please give me some advice if you have any! Thanks!

    This is the look I want (The cabinet on the right)


    But it is doing this, which is a hall directly next to the room. (The cardboard boxes on top do the same thing, I currently have them set to indirect so they don’t.)


    My UV and lightmapping. (No overlapping Faces)


    This is what I get when set to indirect shadow, lighting on the cabinet is fine, shadows vanish, and this is unacceptable.


    This is the mesh set to static; using pre-computed shadowing the shadowing on the bottom of the cabinet is horrible! Even bumping up the res and overriding the light map still makes it look ugly. Went to 128, shouldn’t really have to go that high in all honesty in my opinion.


    Un-checking pre-computed shadows gives me this error, which I don’t understand, because the lightmaps are there, and there is no checkbox to turn them on? However if there is I’m not finding it.


    Someone please help me out here!

    #2
    Is the wall just a plane? If so this is normal. A plane only has one surface, even though you can technically see two with a two-sided material. You'll need 2 surfaces if you want them to be different.

    Comment


      #3
      The wall is a CSG cube additive with a subtractive CSG inside of it. Infact it's actually two CSG additives next to each other with two CSG subtractives inside each one.

      Comment


        #4
        Here you are I posted up a picture of my layout.

        Comment


          #5
          59 views an no one has an answer to this? This is the 4th day I have been trying to solve this issue. Someone please give me a clear answer as to what the deal is here and how to fix it. Although I do appreciate the one persons reply however very vague and with no clear explanation for a solution.

          Comment


            #6
            Originally posted by smurf6020 View Post
            59 views an no one has an answer to this? This is the 4th day I have been trying to solve this issue. Someone please give me a clear answer as to what the deal is here and how to fix it. Although I do appreciate the one persons reply however very vague and with no clear explanation for a solution.
            I've sent you a message on YouTube and we'll see if we can sort this out!


            Seek And Destroy Games
            Tutorials for UDK PC,iOS and 3ds Max
            http://www.youtube.com/user/lexluthornumber1

            Comment


              #7
              Thank you Sir! I replied back to you!

              Comment


                #8
                This issue has not yet been solved, however I would like to thank Lexluthor1 for spending a few hours working with me on this yesterday even though both our efforts were in vain. If anyone else has suggestions please let me know. Thanks!

                Comment


                  #9
                  I'm going to save you the effort of having to waste a year trying to figure this out like it took me. Switch to Lightshadow_Normal in the light options panel, it will remove this(Most likely, it's worked for me ever since I started using it.) effect but it will consume much more performance.
                  OR Alternatively
                  Bump up the Lightmap resolution in the static mesh editor to something like 512 and it will drastically increase the quality of your static shadows.

                  Comment


                    #10
                    Originally posted by pulse0o0 View Post
                    I'm going to save you the effort of having to waste a year trying to figure this out like it took me. Switch to Lightshadow_Normal in the light options panel, it will remove this(Most likely, it's worked for me ever since I started using it.) effect but it will consume much more performance.
                    OR Alternatively
                    Bump up the Lightmap resolution in the static mesh editor to something like 512 and it will drastically increase the quality of your static shadows.
                    Good idea..
                    I spent half the night trying to help this fellow developer and could not solve this the other day....

                    Seek And Destroy Games
                    Tutorials for UDK PC,iOS and 3ds Max
                    http://www.youtube.com/user/lexluthornumber1

                    Comment


                      #11
                      Pulse thanks for your help, I tried that, there was a suggestion I found days after to change the setting to modulated better but I cant do it, it seems it is a bug according to a moderator on here. Thanks again for the reply An again thanks for your time Lex!

                      Comment

                      Working...
                      X