Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Navigation mesh issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navigation mesh issue

    I'm having problems with navmesh when I launch a game normally, while in play in editor everything is fine.
    Some more details of the errors I'm getting and the code I'm using can be found in this thread.
    After some moves of my pawn, as I said in the thread above, I get PATHERROR_GOALPOLYNOTFOUND, and with VerbosePathDebug the console says:
    Code:
    Log: VERBOSE PATH MESSAGE: SEARCH FAILED! InitializeSearch return FALSE!
    Another issue: I tried to make a dynamic navmesh obstacle with the tutorial Creating a dynamic Navigation Mesh Obstacle. It works well in play in editor, but a normal game crashes after some updates of the obstacle shape, and the console says this:
    Code:
    Critical: appError called: Assertion failed: i>=0 && (i<ArrayNum||(i==0 && ArrayNum==0)) [File:d:\depot\unrealengine3\development\src\core\inc\Array.h] [Line: 575]
    Stack: Address = 0xd398d9	(filename not found) [in C:\UDK\UDK-2011-09\Binaries\Win32\UDK.exe]
    I even tried to make a full recook as suggested in a thread, but it didn't help. I'm using UDK september 2011.
Working...
X