Announcement

Collapse
No announcement yet.

Disable Mouse with Kismet

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disable Mouse with Kismet

    Looking to add a kismet method which will temporarily disable any mouse inputs.

    I have a Cursor that appears on screen that can interact with various custom KActor objects in game, so I can click on objects and have them do various things.

    Current controls -
    [A] and [D] control turning left and right.
    [W] and [S] control walking forwards/backwards
    MOUSE moves cursor on screen and can click on objects (left mouse pressed, left mouse released etc.)

    I have various puzzles as well FLASH cutscenes where I need to disable the mouse inputs and re-enable them after certain kismet sequences.

    Heres an example of what I want to do
    Left Mouse click on object
    object does stuff over a period of time
    Player should not be able to do further mouse inputs until sequence is complete.

    I was thinking of making a sequence action or something where I can put in bMousing = false; or something, then have nodes that disabled/enables it, but no luck so far I keep getting no event handler errors so i don't know if im on the right track or not.

    and no turning on Cinematic Mode does NOT disable my mouse at all

    #2
    The Toggle Input node will do it if you can live without all controller input including keyboard... Don't know of a mouse only temporary disable option without doing something custom in uscript...

    Comment


      #3
      Which toggle allows for this?
      New Action -> Toggle -> Toggle Input does not disable my [A] or [D] keys (player turning) and it does not disable the mouse at all

      Comment


        #4
        It does work I can assure you, but we should check the subtleties: I'm using the Feb 2013 build, PC game, Gametype: utgame.

        I'm using it extensively for elevators, to stop players falling out as a side affect of jumping or sliding off etc. All WASD keys and mouse are dead! It may just be something simple in your set-up i.e. you don't have the correct player object reference or the node settings aren't correct.

        To disable input. Add a Toggle Input node with 'Toggle Movement' and 'Toggle Turning' ticked on. Trigger the 'Turn Off' connector in kismet prior to your cut scenes or use a timer or level loaded event to test it out first. I'm using a specific player object grabbed from the instigator of the trigger, but if you have only one player then 'Player 0' should work ok as the node target...

        Comment


          #5
          Simply, create a copy of your room with all objects, but with no mouse interaction and teleport the player to 2nd room at the same previous location and then teleport the player back, when the mission is completed.

          Comment


            #6
            @frankit
            yea it doesn't work for me, it will only disable the W and S input but I can still rotate the camera with A and D and my mouse cursor still moves and I can still click on my kactors.

            @Georjack
            In no way is that simple or even possible. There are various instances where I need to disable mouse inputs in order for the player to not click on objects for half a second, even for the cutscene situation it isn't possible to match the player's rotation upon teleportation, plus that would mean I would have to create about 5 versions of the same level, as objects in the level change quite often.

            I think I might try and just matinee a non clickable invisible cube over everything, really wish I could code this and create my own kismet node.

            Comment


              #7
              I think the problem must be gametype or build related, pity!

              Comment

              Working...
              X