Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Custom fonts not showing on iPad

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Custom fonts not showing on iPad

    I created a new Font in UDK by selecting “New Font” from the list. I didn’t change any of the default settings and selected Comic Sans MS as the font.

    In my game i use the HUD to display the text. And everything is working properly when i run it on PC.

    When i deploy the game to iPad i can’t see the text displayed with my font. But text with unreal fonts are shown.

    when i compare properties of unreal fonts and my fonts, I have noticed there is a property called “Resolution Test Table” available for unreal fonts. My fonts does not have this.


    Any suggestions how i can get custom fonts to work on iPad?

  • #2
    I don't know the proper solution to this, but I ended up adding my fonts to the EngineFonts package to make sure it was packaged.

    Comment


    • #3
      I answered this here http://forums.epicgames.com/threads/...ht=Font+Custom .

      Not the best idea to modify existing packages such as EngineFonts.upk as it's annoying to update.

      Comment


      • #4
        Adding font to EngineFonts does work as suggested by Angel_Mapper.

        Then I tried method suggested by Solid Snake

        I updated DefaultEngine.ini with my package details,
        Code:
        [Engine.PackagesToAlwaysCook]
        +Package=jFont
        But IPhone-UDKEngine.ini did not got updated until i modify MobileEngine.ini file. After that IPhone-UDKEngine.ini does have my package setting.

        Still when i deploy the fonts are not working. Is there anything else I can check to get this working?

        Comment


        • #5
          A few hours spent trying to get that to work is why I said screw it and added them to EngineFonts heheh.

          Comment


          • #6
            Originally posted by wijesijp View Post
            But IPhone-UDKEngine.ini did not got updated until i modify MobileEngine.ini file. After that IPhone-UDKEngine.ini does have my package setting.

            Still when i deploy the fonts are not working. Is there anything else I can check to get this working?
            I had the same thing, changing DefaultEngine.ini was not updating the IPhone-UDKEngine.ini. Once I modified MobileEngine.ini file, IPhone-UDKEngine.ini my packages showed up in the Startup and AlwaysLoaded sections. ALso I could tell in FrontEnd that the package was loading, both from "Adding package ..\..\UDKGame\Content\Rev60\Packages\UI_PKG.upk for cooking..." and listed as a startup package
            "Loading startup packages:
            EngineFonts
            EngineMaterials
            UI_PKG
            SoundClassesAndModes
            UDKFonts
            UI_Fonts_Final"

            However, like wijesijp, it was also still not working for me as well, until... and this may be a fluke, but it seems to have solved my issue:

            I went back into UDK Editor and into the package with the fonts. I was trying to see if I changed any settings on the font if it would have any effect. I unchecked a setting (something like "Bold" or something minor), and saved the package - at which point I got an ominous message saying "UI_PKG is a startup package. Startup packages are fully cooked and loaded when on consoles. ALL CONTENT IN THIS PACKAGE WILL ALWAYS USE MEMORY. Are you sure you want to save it?", though this confirmed that it was actually getting loaded. I said "yes", closed UDK Editor, and deployed again (using Frontend), and now the fonts show up on my iPad correctly. Hopefully they stay that way...

            Comment


            • #7
              I also got it working after reading mhinge post.
              I am also not quite sure how it started working. But last time I didn't have following setting.
              Code:
              [Engine.StartupPackages]
              +Package=jFont

              Comment

              Working...
              X