Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

debug Unreal Script error at vs2011???

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    debug Unreal Script error at vs2011???

    vs2011 debug fail。
    udk tip :
    Application appears to not support the debug engine
    at IPCSendCommandToVS(Int32 cmdId, UInt32 dw1, UInt32 dw2, Char* s1, Char* s2)

    window 7
    vs2011
    udk 2011-12
    nFrings 1.1

    can you help me

    #2
    I am having the same problem

    I am having the same problem. UDK 12-2011.

    Comment


      #3
      I am using pixel mines nfringe. I had to update the program. Now it works perfectly.

      Comment


        #4
        How did you install nFringe for VS 11?

        Comment


          #5
          Yea im curious on how you did this too. I keep getting a "Visual Studio 2005, 2008 or 2010 is not installed on this system" error with the installer.

          Comment


            #6
            Originally posted by Influx Motion View Post
            Yea im curious on how you did this too. I keep getting a "Visual Studio 2005, 2008 or 2010 is not installed on this system" error with the installer.
            This thread is a little dated now, but worth reviving because VS2012 is awesome in every way.

            I fiddled around with it, but the way I got it to work was physically copying the package that nFringe installs to 2010 to the 2012 folder. (Unfortunately you still must have VS2010 installed to do this)

            There are two things I copied -
            C:\Program Files (x86)\Microsoft Visual Studio 10.0\UnrealScript /* I copied the entire folder */
            C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Pixel Mine /* Copy the entire folder again */

            At first this actually didn't work. I restarted initially and nothing happened, the package didn't register. After that, I went about my business assuming that failed and installed the Perforce VS2012 plugin for source control and on the next load of VS2012 there was nFringe.

            I don't pretend to fully understand how VS extensibility works, but hopefully this helps someone or someone else can clarify a better way to do this.

            Comment


              #7
              Originally posted by Shozokui View Post
              At first this actually didn't work. I restarted initially and nothing happened, the package didn't register. After that, I went about my business assuming that failed and installed the Perforce VS2012 plugin for source control and on the next load of VS2012 there was nFringe.

              I don't pretend to fully understand how VS extensibility works, but hopefully this helps someone or someone else can clarify a better way to do this.
              In "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Pixel Mine\Pixel Mine nFringe (UnrealScript)\%nFringe version%", edit the file extension.vsixmanifest to change the version of VS from 10 to 11.


              Originally posted by Shozokui View Post
              This thread is a little dated now, but worth reviving because VS2012 is awesome in every way.

              I fiddled around with it, but the way I got it to work was physically copying the package that nFringe installs to 2010 to the 2012 folder. (Unfortunately you still must have VS2010 installed to do this)

              There are two things I copied -
              C:\Program Files (x86)\Microsoft Visual Studio 10.0\UnrealScript /* I copied the entire folder */
              C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Pixel Mine /* Copy the entire folder again */
              Make sure that you run ' "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe" /setup '. Make sure the path to vs is in quotes.

              That worked for me with nFringed and XNA 4.0 on VS 2012...

              Comment


                #8
                Click image for larger version

Name:	Untitled.jpg
Views:	1
Size:	15.0 KB
ID:	3249167
                Click image for larger version

Name:	Untitled1.jpg
Views:	1
Size:	11.5 KB
ID:	3249168

                just open the properties for your UnrealScript project and copy the path to the UDK.exe.

                See images for debug setting refference.

                Comment


                  #9
                  Originally posted by DrunkReaperMatt View Post

                  Make sure that you run ' "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe" /setup '. Make sure the path to vs is in quotes.
                  I couldnt find devenv.exe at my 2012 vs folder.
                  Nevermind, I didnt stalled the isolated shell stuff.

                  Comment


                    #10
                    You could also edit the MSI to install to VS2012 instead of VS2010. That way you don't even need VS2010 installed.
                    This is what I did and it works great. No problem installing or registering the extension in VS2012.

                    While I didn't notice at first as nFringe worked without problem, the manifest files under both folders in "Extensions/Pixel Mine/*" won't have their lines changed to 11.0 though so you'll have to do that manually.
                    Although not doing that seems to be no problem.

                    (I'm currently running nFringe pre-1.2.23.0)

                    Comment


                      #11
                      Originally posted by Omar007 View Post
                      You could also edit the MSI to install to VS2012 instead of VS2010. That way you don't even need VS2010 installed.
                      This is what I did and it works great. No problem installing or registering the extension in VS2012.
                      How did you changed MSI to do this?
                      I'm trying msidb.exe, but haven't idea what I need change.

                      Comment


                        #12
                        I used the ORCA tool to edit the MSI. The easiest thing you can do is change the checks that use the VS2010 version info to use the VS2012 version info.
                        IE; 10.0 -> 11.0.

                        If you want to do it nicely, you'd add a separate check for VS2012 but that's a bit more work.

                        Comment


                          #13
                          Originally posted by Omar007 View Post
                          You could also edit the MSI to install to VS2012 instead of VS2010. That way you don't even need VS2010 installed.
                          This is what I did and it works great. No problem installing or registering the extension in VS2012.

                          While I didn't notice at first as nFringe worked without problem, the manifest files under both folders in "Extensions/Pixel Mine/*" won't have their lines changed to 11.0 though so you'll have to do that manually.
                          Although not doing that seems to be no problem.

                          (I'm currently running nFringe pre-1.2.23.0)
                          Could you post the steps required to do so or just a link to ur modded MSI? That would be great.

                          Comment

                          Working...
                          X