Announcement

Collapse
No announcement yet.

"Packaged" dedicated server fail to restart level.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Packaged" dedicated server fail to restart level.

    Has anyone successfully restart a level on a dedicated server with a packaged game?

    The game travels successfully and restarts the level when I'm testing on UDK,
    but after cook/package/install it doesn't work.

    Even the UT code hangs when traveling, with and without steam:

    [0004.19] Log: Initializing Steamworks
    [0004.19] Log: Logged in as '^9[^2PT^9] ^3r^1vc'
    [0004.19] Log: LoadMap: DM-Deck?Name=Player?Team=255?TimeLimit=1
    [0004.20] DevMemory: Virtual memory allocation size: 74.11 MByte (77713408 Bytes)
    [0004.62] Log: Game class is 'UTDeathmatch'
    [0004.62] Init: WinSock: Socket queue 131072 / 131072
    [0004.63] Log: NetMode is now 1
    [0004.67] Log: Primary PhysX scene will be in software.
    [0004.67] Log: Creating Primary PhysX Scene.
    [0004.76] Log: Bringing World DM-Deck.TheWorld up for play (30) at 2011.01.24-18.38.16
    [0005.41] Log: Bringing up level for play took: 0.768505
    [0005.41] Log: ########### Finished loading level: 1.216201 seconds
    [0010.42] Init: Game engine initialized
    [0010.42] Log: Initializing Game Engine Completed
    [0070.63] NetComeGo: Open TheWorld 01/24/11 18:39:22 95.136.xx.xx
    [0093.45] Log: Command not recognized
    [0093.45] ScriptLog: START MATCH
    [0093.48] ScriptLog: ServerSetSpectatorLocation UTPlayerController_0 GetStateName():'PlayerWalking' GetViewTarget():'UTPawn_0'
    [0154.45] Log: Command not recognized
    [0187.46] ScriptLog: ProcessServerTravel: ?Restart
    [0187.46] Log: SeamlessTravel to: DM-Deck
    Any ideas?

    Edit:
    I have also this error, I assume it's normal..
    [0000.89] Error: Error, Manifest doesn't exist: ..\..\UDKGame\Script\Manifest.txt

    #2
    Could anyone confirm this is just a problem in my end and try the following please?

    Install UDK, January build.
    Package the game.
    Install the packaged game.
    Run one instance with:
    UDK.exe Server DM-Deck?TimeLimit=1 -nomoviestartup -log -Dedicated -Debug
    And the client with:
    UDK.exe 127.0.0.1 -nomoviestartup -log -Debug -nosound
    And wait 1 minute.

    Comment


      #3
      I have the same problem. I set TimeLimit and GoalScores very high in UDKGame.ini so our game could be tested for a long time without restarting match. Now those 2 values don't seem to be having the same effect, and after 20 minutes match ends but does not restart. At this point I tried what you did (just packaging a new January build) and got the same result as yours... It works great as long as I don't package it. Have you found a fix?

      Comment


        #4
        no, just praying the February build will have this fixed :S

        I guess I should probably try connecting a packaged client to a non-packaged server and only use my home pc as a server until this get's fixed somehow. maybe the only solution is to have a udk license and try to get epic's help.. I dunno..

        Comment


          #5
          Same issue here, i'm currently using the September build.

          Comment


            #6
            So I take nobody knows why this is happening?

            Comment


              #7
              I haven't seen a problem like this with a December-2010 based game, that is a derivative of UT ?

              Comment


                #8
                I'll look into trying the december build, my current gamemodes are indeed derived from UT atm, but that's going to change soon.

                Comment


                  #9
                  I haven't seen the restarting problem from lack of trying, but I do see the Manifest error when launching the packaged game. Mine is not UT derived.

                  Comment


                    #10
                    Well, I'm still having the same problem with the February build.

                    This is what I did.

                    Install UDK, February build.
                    Package the game.
                    Install the packaged game.

                    Run server with:
                    UDK.exe Server DM-Deck?TimeLimit=1 -nomoviestartup -log -Dedicated -Debug
                    And the client with:
                    UDK.exe 127.0.0.1 -nomoviestartup -log -Debug -nosound
                    After one minute the match finishes, server starts restarting the level and then it hangs.
                    Doesn't start the new level, the client gets disconnect and the server doesn't accept any more clients.

                    Am I missing something?

                    Comment


                      #11
                      just try: udk server dm-deck?timelimit=1

                      ? -nostartupmovies -log don't really make sense on a server, -dedicated isn't a switch, and -debug i'm not sure if it's a switch, or if it would be causing the problem..

                      Comment


                        #12
                        But if this happens with a clean install of February, where the hell do we start looking for where it goes wrong. It acts like it restarted just fine, but crashes.

                        I'm going to weed through the server code soon, never actually looked into there before, if someone knows what classes handles restart it'll make my job a bit easier :P

                        Sorry for the necro bump, but this is kinda an important issue.

                        Comment


                          #13
                          Originally posted by Blade[UG] View Post
                          just try: udk server dm-deck?timelimit=1

                          ? -nostartupmovies -log don't really make sense on a server, -dedicated isn't a switch, and -debug i'm not sure if it's a switch, or if it would be causing the problem..
                          doesn't work either.

                          [0003.96] Init: Command line: DM-Deck?TimeLimit=1
                          Going to try on another pc now.

                          edit: the other pc doesn't support SM3. fail -.-'

                          Comment


                            #14
                            the other pc doesn't support SM3. fail -.-'
                            udk server mapname?game=gamepackage.gameclass -nullrhi

                            Comment


                              #15
                              I can't try on my other pc right now, but I've tried on yet another one and it works O.O

                              My pc has Win7Pro64 on an Intel Q6600 and it didn't work.
                              But worked on a Win7Home64 on an AMD Phenom II X4.

                              I'm going try on another computer with an Intel Q6600 and see what happens. If it works, I'll try again on my computer and start shutting down apps seeing if there is any think conflicting. :\

                              Tomorrow I'll try that command line Blade, thanks.

                              Comment

                              Working...
                              X