Announcement

Collapse
No announcement yet.

How to disable doublejump?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    C:\UDK\UDK-2011-09\Development\Src\UTGame\Classes\utpawn.uc

    but its better to extend this file rather than alter it.

    Code:
    class myPawn extends utPawn
    
    defaultproperties
    {
        MaxMultiJump=0
    }

    Leave a comment:


  • replied
    Where i can find the file to add this code?

    Leave a comment:


  • replied
    Originally posted by Robert_F View Post
    Yup no problem

    thanks ...

    Leave a comment:


  • replied
    Yup no problem

    Leave a comment:


  • replied
    Yeah that's it and it directly worked! That's rare
    Since the original files shouldnt be edited I made an entry in the defaultproperties of my custom PlayerController. Thanks much

    Leave a comment:


  • replied
    How I disabled it was to do this. Open the UTPawn.uc

    Search for the line:

    Code:
    MaxMultiJump=1
    and change it to 0. You can make it higher to have like a triple jump and so on.

    Leave a comment:


  • replied
    I managed to disable double side-jump, wasn't even that hard (to me). Just using the process move function from the camera technical guide in the udn and deleted the lines containing:

    Code:
    if ( (DoubleClickMove == DCLICK_Active) && (Pawn.Physics == PHYS_Falling) )
                      DoubleClickDir = DCLICK_Active;
                   else if ( (DoubleClickMove != DCLICK_None) && (DoubleClickMove < DCLICK_Active) )
                   {
                      if ( UTPawn(Pawn).Dodge(DoubleClickMove) )
                         DoubleClickDir = DCLICK_Active;
                   }
    Withouth these lines in your custom Process Move the double sidejump is disabled

    Not to be misunderstood, I still need to know how to disable double-jump-jump^^

    Leave a comment:


  • replied
    this is relevant to my interests
    also double A/D for side jump

    Leave a comment:


  • started a topic How to disable doublejump?

    How to disable doublejump?

    Title sais everything. I had jumping disabled in my playercontroler so I just added
    Code:
    if ( bPressedJump )
               {
            Pawn.DoJump( bUpdating );
            bDoubleJump = false;
               }
    to my code but doublejump is still available o_O Why?
Working...
X