Announcement

Collapse
No announcement yet.

Dynamic Lighting: Getting Play-on-PC SHADOWS to match PIE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Dynamic Lighting: Getting Play-on-PC SHADOWS to match PIE

    * - Been tweaking World_Properties & DDL light / shadow settings forever, but can never get the dark shadows of Play-On-PC to match PIE and be lighter!

    * - For example, when the DDL property Whole-Scene Dynamic-Shadow-Radius is large, everything in front of the player gets over-darkened, to the point of being horribly grim...

    * - Apart from this, the lighting is good & matches PIE. Its interesting how drastically you can alter the light in PIE & not have it propagate to Play-On-PC / Packaged games???

    * - By the way the level in question is open-world with fully-dynamic sun... Can anyone share some wisdom here? Thanks in advance...

    #2
    its always been this way as far as I remember.i think it has to do with the editor being 64 bit as opposed to the game being 32.

    the only workaround ive found is a very low level skylight in the scene.

    Comment


      #3
      Thanks for the info Gaz!

      Its a tricky one. I was hoping it wouldn't come to that because the top half of my open-world-level is set in space and of course a skylight indiscriminately lights everything and can't be rotated either. UnrealEverything suggested things to try too, so I'll keep working away & see if there's any other option. Good to know its a problem shared. Cheers!

      Comment


        #4
        as far as I know the only difference between PIE and PPC/standalone comes when lighting isn't built.
        in your case it shouldn't matter because you're using dynamic lighting, but are you sure you're really telling unreal to go for dynamic lighting? in your level worldinfo properties, under lightmass disable the use of lightmass and global illumination entirely, then build the lights again so the change propagates (will be instant), save, play.

        in any case, which is the intended behavior for you? the pitch-black shadows or the slightly ambient-lit shadows? because when using fully dynamic lighting what you're meant to get is pitch-black shadows (and a skylight is the way to "fix" it - if it doesn't behave correctly for you we can look into it)

        Comment


          #5
          Thanks Chosker. Regarding a disable / toggle Lightmass on/off switch... I've been following gaz661's directions which are to turn off 'use precomputed shadows' for every mesh, tick-on bForceNoPrecomputedLighting = True in World Properties. Then untick 'Use Lightmass' and build lighting. But even with GI unticked the problem continues... ...

          Yep, its the pitch black shadows and use of Whole Scene Radius in the DDL that blankets the level is large patches of darkness. The skylight in particular brightens structures made of transparent material. As of writing I'm looking at dialling these down to compensate for the skylight...

          Comment


            #6
            in world properties...
            'Use Global Illumination' = uncheck
            'Force no precomputed lighting' = check

            these get you purely dynamic lighting. you don't need to do it for every mesh really

            so if I understand correctly you don't want pitch-black shadows. in that case you really need a skylight and then tune your materials to account for any inconsistencies (I myself had none)
            if you then want to dim if for objects in outer space I'd suggest making a custom class that extends skylight that modifies the values by code based on some criteria (like the Z position of the local player controller)

            Comment


              #7
              Cheers Chosker!

              Comment

              Working...
              X