No announcement yet.

UDK won't compile the code after tweaking the system clock

  • Filter
  • Time
  • Show
Clear All
new posts

    UDK won't compile the code after tweaking the system clock

    I have a serious problem here, after tweaking the system clock to add one hour, UDK has suddenly stopped compiling scripts and there is no way to make it compile again !

    Normally, when I edit a class and then launch UDK it does automatic recognise the changes and compile scripts, but now it just skip it !

    I tried to switch the system clock to one hour earlier without effects, then I tried to switch the date to September and it was always compiling but I couldn't launch the game. After switching to normal time the compiling actually had no effect.

    So the development is now completely on hold since I can not compile the code any more ! Can somebody help ?!

    I also tried to reinstall UDK and after a full recompiling it does still skip the compile process !

    After some test, it seems that changes made to classes of UTGame are recognised, but not mine !
    The only way I managed to compile my classes so far is to delete the compiled .u classes and then make a full recompile with front end...


      Make sure that your computer clock has ran out of battery that atleast made mine, to not compile any classes at all.
      It happend to me, my computer clocks battery ran out of energy and somehow UDK did not want to compile my classes.

      So perhaps also can be related with somethign of your clock.
      Well one can go and resintall windiws or compile using frintend.


        Okay, I actually didn't need to change the battery of the mother board (bought just this year) but simply letting the clock to automatically sync with did the trick !


          Awsome, so it was time related ? like my problem ? cool cool...