Announcement

Collapse
No announcement yet.

Out of virtual memory crash?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Sorry, I may have been too hasty in posting this problem.

    I repackaged and went through the custom installer process again, and this time it seems to work.
    There must have been a random corruption somewhere along the way.

    Leave a comment:


  • started a topic Out of virtual memory crash?

    Out of virtual memory crash?

    So I am finally ready to release the next update to my game.... then suddenly as it turns out, my game's main level crashes when loaded in the compiled game.

    It is fine in the editor, and fine when I play the unpackaged game. But as soon as I launch as an installed game, it crashes. This is particularily frustrating since hardly any changes, and definitely nothing that could cause something like this, has been done to the map since the last version, which worked fine.

    Code:
    [0039.57] Log: Assembled 418 auto-complete commands, manual: 90, exec: 302, kismet: 0
    [0063.15] Log: LoadMap: mecharena?Name=Player?Team=255
    [0063.15] Log: --- LOADING MOVIE START ---
    [0063.21] ScriptWarning: Invalid user index (255) specified for ClearReadProfileSettingsCompleteDelegate()
    	OnlineSubsystemSteamworks Transient.OnlineSubsystemSteamworks_0
    	Function OnlineSubsystemSteamworks.OnlineSubsystemSteamworks:ClearReadProfileSettingsCompleteDelegate:00FE
    [0063.28] Critical: appError called: Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.
    [0063.28] Critical: Windows GetLastError: The system cannot find the file specified. (2)
    [0066.08] Log: === Critical error: ===
    Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.
    
    Address = 0x7522c41f (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]
    Address = 0x14c34b1  (filename not found) [in C:\UDK\Modulated V002\Binaries\Win32\UDK.exe]
    Address = 0x14ce233  (filename not found) [in C:\UDK\Modulated V002\Binaries\Win32\UDK.exe]
    Address = 0x14575eb  (filename not found) [in C:\UDK\Modulated V002\Binaries\Win32\UDK.exe]
    I've been looking at other threads for this issue, and all I could pretty much find was to not use version incompatible pakages, but I've stuck to the same UDK version all along.
Working...
X