Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

[SOLVED] How to switch off speedtree wind

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] How to switch off speedtree wind

    Hi to everyone,

    Wind effect with speedtree object is really nice, but I have a task to make trees without any motion. I have tried to put zero into wind strength property of a speedtree object but it gives no effect. Where are the real parameters to control the wind ?

  • #2
    there are wind properties in speedtree and in udk, try set them up as wind-0 in speedtree and udk properties

    Comment


    • #3
      Originally posted by Buddhist Punk View Post
      there are wind properties in speedtree and in udk, try set them up as wind-0 in speedtree and udk properties
      He already said he tried that and I can confirm that doesn't work. You can increase strength using that property but can't shut it off. Only way I'm aware of is to turn it off in SpeedTree and recompile.

      Comment


      • #4
        Originally posted by taz1004 View Post
        He already said he tried that and I can confirm that doesn't work. You can increase strength using that property but can't shut it off. Only way I'm aware of is to turn it off in SpeedTree and recompile.
        I have tried to turn off "Include wind" property in SpeedTree compilation, but in that case UDK is crashing when I want to import my tree. Are there some other more stable flags to switch off ?

        Comment


        • #5
          let me give it a go and see, i know that turning wind off in udk does nothing, will get back to you

          Comment


          • #6
            yip i got wind off!!!
            in speedtree modeler,
            under wind everything set to "0"
            ripple u and v and scale aswell.
            ( to find the wind easierly, selevt the truck of the tree, in the bottom right window.
            then in the top left of the program there is a mousepointer with question mark, click that
            and select wind in the list, set all under wind to zero

            um, just to check you are using speedtree compiler to compile them 1st before importing to udk?

            let me know if u got it working

            p.s if you ever get lighting crashes, it may be cause u made a tree to large in udk, it took me like 2 weeks to figure that out

            Comment


            • #7
              I have tried to put everything in zero for wind properties, but It doesn't help.
              Here is my tree - http://dl.dropbox.com/u/30632240/ScaryTree.rar

              > um, just to check you are using speedtree compiler to compile them 1st before importing to udk?

              Yes, I'm always recompiling trees.

              > p.s if you ever get lighting crashes, it may be cause u made a tree to large in udk, it took me like 2 weeks to figure that out

              I also have found this thing, so I'm trying to control tree mesh density for using in UDK.

              Interesting, are there some flags in Engine configuration to switch off wind at all like a feature... or the only way out for me is not to use speedtree at all, to model trees as a static mesh...

              Comment


              • #8
                ok i got, finally
                at the top of the main window, with all the icons, there is a flag, set it on( wind)
                then click the fan which appears under the light.
                it properties should appear on the left, set everything to zero
                global, primary and secondary leaves, everything set em to zero.
                compile etc,
                when i take it into udk, its still as a stiff dead dead,
                let me know,
                p.s i didnt get any crashes importing or anything, using march 2012 udk,
                speedtree5.0.2

                Comment


                • #9
                  Originally posted by Buddhist Punk View Post
                  ok i got, finally
                  at the top of the main window, with all the icons, there is a flag, set it on( wind)
                  then click the fan which appears under the light.
                  it properties should appear on the left, set everything to zero
                  global, primary and secondary leaves, everything set em to zero.
                  compile etc,
                  when i take it into udk, its still as a stiff dead dead,
                  let me know,
                  p.s i didnt get any crashes importing or anything, using march 2012 udk,
                  speedtree5.0.2
                  Yes, you are right. Many thanks for helping, this is a real way for controlling wind behavior!

                  Comment


                  • #10
                    sure i dont know whyu there are so many wind controls that do nothing really, very odd

                    Comment

                    Working...
                    X