Announcement

Collapse
No announcement yet.

Having an issue with shadows. I really need a hand here.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Having an issue with shadows. I really need a hand here.

    I'm having an issue with my shadows not appearing after render. Whenever I finish my build, the shadows disappear. If I move the light, they come back, but after rendering again they're gone. I'd like to have my shadows have a harder edge. All of my ceiling lights are emissive, but they won't cast any shadows.

    Here's what I have...



    Here's what I want...(When I build my lighting the shadows go away)



    So, does anyone know how to fix the issue I'm having? My point light won't cast shadows after building either. I'm not sure what my problem is. The only way I can get my shadows to work (like in the second picture) is by clicking on my point light, and moving it.

    Here's how all of my emissive lights are set up


    #2
    replace your current light with a point light moveable or toggleable and that will do th etrick. If not just tick the dynamic channel on your lightning channel and uncheck the static one.

    Comment


      #3
      Thanks for the reply, but unfortunately none are doing anything. The dynamic checked didn't work, and I tried to use a moveable point light, but that didn't work either. Seems like no matter what I try I can't get working shadows. Is it because of how much light I actually have? I've also completely unchecked all of my ceiling lights to use emissive light and tried only using a point light. but that still gave me no shadows. UDK is actually really frustrating sometimes.

      Comment


        #4
        you want to have sharp edge baked shadow or dynamic shadows ?

        Comment


          #5
          A sharp baked edge would be fine. They don't need to be dynamic. I'd like it to look simular to the second picture, but with the shadows coming from the ceiling.

          As you can imagine, I can't use a directional light, because the roof is blocking that. I've tried just about everything I know. I almost think my udk is bugged

          Comment


            #6
            You want to up the lightmap resolution on your meshes / brush surfaces.

            Comment


              #7
              I up'd from 32 to 128 without a difference at all. I appreciate the advice, but still haven't found a solution

              Comment


                #8
                Is the ground BSP? If it is then use smaller numbers for the Lightmap Resolution. If that is BSP try using 16 for example.

                Comment


                  #9
                  didn't work. I tried using other numbers as well as 16. I can't see anything happen. Everything just looks like the first picture after building. Whats weird though is when I grab the point light to move it, shadows pop up and work fine until I build again. I don't understand it.

                  Comment


                    #10
                    Those shadows are temporary just so you can preview things before building your lighting.

                    Your issue is that your shadow map resolutions aren't high enough. If you're using a static mesh you need to go into each static mesh and set the resolution higher, for something like the floor try 512, and go from there. If it still isn't working then perhaps you don't have the proper UV's setup for your meshes. You should have at least 2 UV channels for your mesh. By default #0 is your UV's for your material textures, and #1 is for your lightmap, you can create new UV's for your lightmap by using the Generate Light Map UV's option.

                    Comment


                      #11
                      Your UDK isn't bugged. The shadows that appear in the second picture are preview shadows. If you want those after bake (it won't need bake because those are dynamic) all you have to do it add a point light movable then select all of your meshes and uncheck precomputed shadows go back into your movable pointlight and set the lightshadow to. . .
                      "Lightshadow_Normal" instead of "Lightshadow_Modulated"
                      Here is a picture of a scene a I set up using the method stated. I also threw in a normal pointlight with a brightness of .1 to simply fill up the room with lightmass so the dynamic shadows wouldn't be completely black.


                      Uploaded with ImageShack.us
                      The reason you want to the lightshadow to be Normal instead of modulated is because when using modulated shadows from other objects are visible through other static meshes in your scene as seen here.


                      Uploaded with ImageShack.us

                      Comment


                        #12
                        Thanks for the help, I'll try a second UV and see where that takes me

                        Comment


                          #13
                          When I changed the resolution down to "1" or close to it, my shadows appeared the way I wanted them to. All of my meshes now have a second UV map as well. Looks like one of the solutions solved my problem

                          Comment

                          Working...
                          X