Announcement

Collapse
No announcement yet.

[HELP] Mutator Implementation Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [HELP] Mutator Implementation Help

    Okay, so I started playing around with the UDK today and I wanted to make a quick Mutator so I could understand the basics. I ran into a problem when trying to get the mutator to work. I was able to compile it, have it show up in the mutator list, but when active nothing would happen. The way I had to get it to work was to copy the MyMod.u file from UDKGame\Unpublished\CookedPC\Script to UDKGame\Script. Once I did that the mutator started to work. The problem I have with this, is I really do not want to have to do that every time I make a change to the mutator. Should the Make command be doing this for me and I have some configuration set wrong?

    Also when I try to do a Full Recompile Make, it throws an error when it is loading my mutator file. Could that have something to do with the problem?

    Thank you.

    #2
    It sounds like you've configured something in your ini file as if it were UT3, not UDK .. what changes did you make to your INI files?

    Comment


      #3
      Reply

      I added the line ModPackages=SuperGrav (SuperGrav is the name of the test mutator I am using) to the UDKEditor.ini file. I added a SuperGrav.ini file with ClassName=SuperGrav.Supergrav and a few other settings that I cant recall at the moment. I also added a localization int file where I specified the display name of the mutator. I think that is all I did. I was following a few tutorials so there might have been a few other small things.

      Comment


        #4
        hello

        (sorry for my poor english skill)

        there are two ways to compile the contents you made.

        1. 'modpackagesinpath' line in DefaultEditorUDK.ini

        2. 'modeditpackages' line in DefaultEngineUDK.ini

        these are different each other. the line in number 1 is cooking for not only your editor but also UDKGame. I guess you are using this line for compiling.

        but the line in number 2 is cooking for only your editor.

        if you don't want to compile for your UDKGame, delete the line in DefaultEditorUDK.ini(or UDKEditor.ini)

        and you could compile for editor adding a line in DefaultEngineUDK.ini

        Comment

        Working...
        X